The Inbox Manager component generates high CPU-utilization on an SMS site server (832998)



The information in this article applies to:

  • Microsoft Systems Management Server 2.0

Important This article contains information about modifying the registry. Before you modify the registry, make sure to back it up and make sure that you understand how to restore the registry if a problem occurs. For information about how to back up, restore, and edit the registry, click the following article number to view the article in the Microsoft Knowledge Base:

256986 Description of the Microsoft Windows Registry

SYMPTOMS

Your Microsoft Systems Management Server (SMS) 2.0 site may process data slowly, and this may cause a backlog of files on the site server computer. In this scenario, Performance Monitor may indicate that the SMS_Executive service is generating high CPU-utilization. Specifically, the Inbox Manager component continuously logs entries to the Inboxmgr.log file, and this indicates that it is analyzing various Inboxes -- for example, the Offerinf.box and the Pkginfo.box folders. Additionally, Replication Manager may process incoming files from the Despooler much more slowly than expected.

In addition to these issues, Inbox Manager may continuously add new entries to the following registry key:

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\SMS\Inbox Source\Inbox Instances

When this issue occurs, the size of the registry continues to grow, and this may cause quota errors in the registry.

CAUSE

These issues may occur when more than one client access point (CAP) exists on the same server. The first CAP is located in the CAP_XXX folder, where XXX is the SMS site code. Additional CAPs may have been created on a network share on the existing CAP computer.

RESOLUTION

Warning If you use Registry Editor incorrectly, you may cause serious problems that may require you to reinstall your operating system. Microsoft cannot guarantee that you can solve problems that result from using Registry Editor incorrectly. Use Registry Editor at your own risk.To resolve this problem, follow these steps:
  1. In the SMS Administrator Console, expand Site Hierarchy\SMS\Site Settings.
  2. Click Site Systems to review the CAPs that are installed for your site.
  3. Right-click each CAP where the Type column contains "Windows NT Share," and then click Delete. Click Yes when you are prompted to confirm the deletion of the object. After you have finished, make sure that there is only one CAP listed.
  4. Wait several minutes to give SMS a chance to process the changes.
  5. Click Start, point to Programs, point to Administrative Tools, and then click Services.
  6. Stop all SMS services.
  7. Click Start, point to Run, and then type regedit.

    Note Type regedt32 if you are running Microsoft Windows NT 4.0.
  8. Expand the following registry key:

    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\SMS\Inbox Source\Inbox Instances

  9. Delete each subkey where the NAL Path entry value contains the network share location for the CAP shares that you deleted in step 3.
  10. Restart the SMS services.

MORE INFORMATION

There must be only one CAP on any particular server computer. Multiple CAPs on the same computer do not provide any additional benefit. In a typical SMS 2.0 installation, an SMS 2.0 CAP computer will have only 50 to 70 registry subkeys in the HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\SMS\Inbox Source\Inbox Instances subkey.

When another CAP is created on a computer that contains an existing CAP, duplicate subkeys are created that point to the same Inbox folders. Each subkey contains a Location Type entry with a value of 3. When the Inbox Manager component cycle starts, each Inbox folder is reviewed; when many additional Inboxes are added to the registry, the Inbox Manager enumerates the registry subkeys and therefore runs continuously.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section of this article.

Modification Type:MinorLast Reviewed:6/13/2005
Keywords:kbCAP kbInboxMgr KbClientServer kbusage kbPerformance kbnofix kbBug KB832998 kbAudITPRO