Terminal Services stops responding on your Windows Server 2003 server (832971)



The information in this article applies to:

  • Microsoft Windows Server 2003, Web Edition
  • Microsoft Windows Server 2003, Standard Edition
  • Microsoft Windows Server 2003, Enterprise Edition
  • Microsoft Windows Server 2003, 64-Bit Enterprise Edition

SYMPTOMS

After Terminal Services has run for three or four days on your Microsoft Windows Server 2003-based computer, the following symptoms may occur:
  • Terminal Services stops responding (hangs).
  • You cannot log off any open Terminal Services sessions.
  • You cannot log on at the console of the Terminal Services computer.
  • You cannot log on to a Terminal Services session from another computer. When you try to log on to a Terminal Services session from another computer, the Winlogon process starts, the session stops responding, and the session screen becomes blank.
  • Your computer becomes sluggish, and eventually stops responding (hangs).
You must restart Windows Server 2003 to recover from this problem.

CAUSE

This problem may occur if a Terminal Services session has not shut down completely. This problem may occur even if the problem session has been logged off the Terminal server. A session may not shut down completely if a process in the session is waiting for the redirector to process a shadow I/O Request Package (IRP). The process that is waiting for the redirector prevents a program from closing, and the session cannot shut down until the program closes.

RESOLUTION

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Windows Server 2003 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

No prerequisites are required.

Restart requirement

You must restart your computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
Date         Time     Version         Size      File name   Platform
------------------------------------------------------------------
25-Nov-2003  22:28    5.2.3790.105    394,752   Mrxsmb.sys  x86
25-Nov-2003  22:28    5.2.3790.105    157,696   Rdbss.sys   x86
Date         Time     Version        Size       File name   Platform
--------------------------------------------------------------------
25-Nov-2003  22:32    5.2.3790.105  1,121,792   Mrxsmb.sys  IA-64
25-Nov-2003  22:32    5.2.3790.105    463,872   Rdbss.sys

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section of this article.

MORE INFORMATION

For additional information, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates


Modification Type:MinorLast Reviewed:10/27/2005
Keywords:kbHotfixServer kbQFE kbBug kbfix kbQFE kbWinServ2003preSP1fix KB832971 kbAudITPRO