You receive a "File Not Found" error message when you use DCPROMO /ADV to restore a system state (832942)



The information in this article applies to:

  • Microsoft Windows Server 2003, Web Edition
  • Microsoft Windows Server 2003, Standard Edition
  • Microsoft Windows Server 2003, Enterprise Edition
  • Microsoft Windows Server 2003, 64-Bit Enterprise Edition

SYMPTOMS

When you run the dcpromo command together with the /adv switch to specify the drive and the path to the restored system state in the Active Directory Installation Wizard, you may receive the following error message:
Error File Not Found

CAUSE

This problem may occur if the following conditions are true when you try to restore the system state:
  • A site is deleted from the Active Directory directory service forest.
  • The deleted site is the first to appear alphabetically in this service forest.

RESOLUTION

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Microsoft Windows Server 2003 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services phone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

No prerequisites are required.

Restart requirement

You do not have to restart your computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel. Windows Server 2003
   Date         Time   Version       Size       File name
   ------------------------------------------------------
   13-Jan-2004  19:44  5.2.3790.109  1,055,232  Esent.dll        
   13-Jan-2004  19:44  5.2.3790.118  1,526,784  Ntdsa.dll
Windows Server 2003 64-Bit Edition
   Date         Time   Version       Size       File name  Platform
   ----------------------------------------------------------------
   13-Jan-2004  19:44  5.2.3790.109  2,605,056  Esent.dll  IA-64
   13-Jan-2004  19:44  5.2.3790.118  4,036,096  Ntdsa.dll  IA-64

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For additional information, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates


Modification Type:MinorLast Reviewed:10/28/2005
Keywords:kbHotfixServer kbQFE kbBug kbfix kbQFE kbWinServ2003preSP1fix KB832942 kbAudITPRO