The Patch UI Monitor component may leak threads when a user on an SMS 2003 Advanced Client computer postpones a Software Update. (832888)



The information in this article applies to:

  • Microsoft Systems Management Server 2003

SYMPTOMS

When you use the Software Update Services (SUS) feature in Microsoft Systems Management Server (SMS) 2003 to deploy software updates to SMS 2003 Advanced Client computers, the Patch UI Monitor component may leak one or more handles every time that a user on an SMS 2003 Advanced Client computer postpones the installation of the software update.

CAUSE

This problem occurs when the Patch UI Monitor component cannot release handles correctly. By default, the software update advertisement schedule is one time per week. Therefore, the CCMExec service may have 5 to 10 handle leaks in a week. However, if the advertisement schedule is changed to one time per day, the CCMExec may have 35 to 70 leaked handles in a week. The number of leaked threads may increase if multiple patches are advertised.

RESOLUTION

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next is that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question. The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version            Size    File name
   -----------------------------------------------------------------
   15-Dec-2003  23:51  2000.80.194.0     274,489  Ntwdblib.dll     
   15-Dec-2003  23:51  2.50.2726.108     111,616  Patchuimonitor.dll  
   15-Dec-2003  23:51  2.0.1493.5011     855,312  Preinst.exe      
   

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For additional information, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates


Modification Type:MinorLast Reviewed:10/5/2005
Keywords:kbfix kbBug kbSMSTopazFix kbQFE KB832888 kbAudITPRO