FIX: You receive a "Your personal site cannot be created because a site already exists with your username" error message when you click My Site in SharePoint Portal Server 2003 (832863)



The information in this article applies to:

  • Microsoft Office SharePoint Portal Server 2003


SYMPTOMS

In Microsoft Office SharePoint Portal Server 2003, when you log on to the portal and then click My Site, you may experience one or both of the following symptoms:
  • You receive the following error message:
    Your personal site cannot be created because a site already exists with your username. Contact your site administrator for more information.
  • The Create My Site page appears, but nothing happens.
As a result, you cannot connect to or create your personal site.

CAUSE

This problem may occur if the name of the user account that you are currently logged on to the portal as contains one or more of the following characters:
  • \
  • .
  • @
  • "
  • #
  • %
  • &
  • *
  • :
  • <
  • >
  • ?
  • {
  • }
  • |
For example, you may experience the symptoms that are described in the "Symptoms" section of this article if the name of your user account is "#User1" (without the quotation marks).

RESOLUTION

This problem was first fixed in a hotfix that is now contained in a service pack. If you installed the latest SharePoint Portal Server 2003 service pack, you do not have to install the hotfix.

Service pack information

This problem is corrected in Microsoft SharePoint Portal Server 2003 Service Pack 1.

To resolve this problem, obtain the latest service pack for Microsoft SharePoint Portal Server 2003. For additional information, click the following article number to view the article in the Microsoft Knowledge Base:

889380 How to obtain the latest service pack for SharePoint Portal Server 2003

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next SharePoint Portal Server 2003 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.
The English version of this hotfix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.

Date         Time   Version            Size    File name
------------------------------------------------------------------------------
25-Nov-2003  19:41  11.0.5704.12    4,602,432  Microsoft.SharePoint.Portal.dll       
25-Nov-2003  18:11  11.0.5704.12       13,312  Putildm.dll
25-Nov-2003  18:11  11.0.5704.12        8,192  Spsutil.dll

Note This update requires Microsoft Office SharePoint Portal Server 2003.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section of this article.
This problem was first corrected in SharePoint Portal Server 2003 Service Pack 1.

MORE INFORMATION

For more information about My Sites, see the "Managing Personal Sites" topic in the "Administration" section of the Microsoft Office SharePoint Portal Server 2003 Administration Guide. The Microsoft Office SharePoint Portal Server 2003 Administration Guide (Administrator's Help.chm) is located in the Docs folder in the root directory of the SharePoint Portal Server 2003 CD.

For more information about SharePoint Portal Server, visit the following Microsoft Web site:

Modification Type:MinorLast Reviewed:10/27/2005
Keywords:kbHotfixServer kbQFE kberrmsg kbWebServer kbSharePtPortalSvr2003preSP1fix kbQFE kbfix kbBug KB832863 kbAudITPRO