Icons are not displayed for Adobe PDF documents that are listed in the search results when you search your portal site in SharePoint Portal Server 2003 (832809)



The information in this article applies to:

  • Microsoft Office SharePoint Portal Server 2003


SYMPTOMS

When you search for Adobe Portable Document Format (PDF) documents on your Microsoft Office SharePoint Portal Server 2003 portal site, the PDF documents are returned in the search results as you expect. However, the icon for each of the PDF documents that are listed in the search results is missing. Additionally, on the Specify File Types to Include page of the portal site, the icon that is typically displayed next to the .pdf extension is missing.

CAUSE

This issue may occur either if the Adobe PDF IFilter is not configured correctly on the server or if SharePoint Portal Server 2003 is not configured correctly to index the .pdf file type.

RESOLUTION

To resolve this issue, make sure that the Adobe PDF IFilter and the .pdf file type are configured correctly on the server. To install Adobe PDF IFilter 5.0 and configure SharePoint Portal Server 2003 to index .pdf files, follow these steps:
  1. Download Adobe PDF IFilter 5.0 from the following Adobe Web site:
  2. Stop the IIS Admin service. To do so:
    1. Click Start, point to Administrative Tools, and then click Services.
    2. Right-click IIS Admin Service, and then click Stop.
  3. Run the Adobe PDF IFilter 5.0 Setup program to install the filter on the server.
  4. Register the Adobe PDF IFilter. To do so:
    1. Click Start, and then click Run.
    2. In the Open box, type cmd, and then click OK.
    3. Switch to the folder that contains the Adobe PDF Filter 5.0 files. For example, switch to the following folder:

      Drive:\Program Files\Adobe\PDF IFilter 5.0

    4. Type regsvr32.exe pdffilt.dll, and then press ENTER.
    5. If you receive a message that the operation was successful, click OK .
    6. Type exit, and then press ENTER to quit the command prompt.
  5. Copy the .gif file that you want to use for the icon to the following folder on the server:

    Drive:\Program Files\Common Files\Microsoft Shared\Web Server Extensions\60\Template\Images

  6. Edit the Docicon.xml file to include the .pdf extension. To do so:
    1. Start Notepad, and then open the Docicon.xml file. The Docicon.xml file is located in the following folder on the server:

      Drive:\Program Files\Common Files\Microsoft Shared\Web server extensions\60\Template\Xml

    2. Add an entry for the .pdf extension. For example, add a line that is similar to the following to the Docicon.xml file, where NameofIconFile is the name of the .gif file:

      <Mapping Key="pdf" Value="NameofIconFile.gif"/>

    3. On the File menu, click Save, and then quit Notepad.
  7. Restart the server.
  8. Add the .pdf file type to the content index. To do so:
    1. Connect to the portal site, and then click Site Settings.
    2. On the Site Settings page, under Search Settings and Indexed Content, click Configure search and indexing.
    3. On the Configure Search and Indexing page, under General Content Settings and Indexing Status, click Include file types.
    4. On the Specify File Types to Include page, click New File Type.
    5. On the Add File Type page, type pdf in the File extension box, and then click OK.
  9. Update the context indexes for portal content and for non-portal content. To do so:
    1. On the Site Settings page of the portal site, under Search Settings and Indexed Content, click Configure search and indexing.
    2. On the Configure search and indexing page, under Content Indexes, click Manage content indexes.
    3. On the Manage Content Indexes page, click the down arrow next to the name of the index that you want to update, and then click Start Full Update.

MORE INFORMATION

For more information about how to administer and configure SharePoint Portal Server 2003, see the Microsoft Office SharePoint Portal Server 2003 Administration Guide. The Microsoft Office SharePoint Portal Server 2003 Administration Guide (Administrator's Help.chm) is located in the Docs folder in the root directory of the SharePoint Portal Server 2003 CD.

For more information about SharePoint Portal Server 2003, visit the following Microsoft Web site: For more information about the Adobe PDF IFilter, visit the following Adobe Web site:
The third-party products that this article discusses are manufactured by companies that are independent of Microsoft. Microsoft makes no warranty, implied or otherwise, regarding the performance or reliability of these products.
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Modification Type:MinorLast Reviewed:12/10/2004
Keywords:kbdisplay kbprb KB832809 kbAudITPRO