Event ID 1003 and Event ID 1015 appear in the application log each time that you restart Windows Server 2003 (832790)



The information in this article applies to:

  • Microsoft Windows Server 2003, Enterprise Edition
  • Microsoft Windows Server 2003, Standard Edition

SYMPTOMS

Every time you restart your server, the following two events appear in the application log in the Event Viewer:Event Type: Warning
Event Source: EvntAgnt
Event Category: None
Event ID: 1003
Date: date
Time: time
User: N/A
Computer: servername
Description: TraceFileName parameter not located in registry; Default trace file used is . Event Type: Warning
Event Source: EvntAgnt
Event Category: None
Event ID: 1015
Date: date
Time: time
User: N/A
Computer: servername
Description: TraceLevel parameter not located in registry; Default trace level used is 32.

CAUSE

This problem occurs if you install the Simple Network Management Protocol (SNMP) service but you do not also configure this service. These error events are logged by the SNMP service when you restart the computer. If the Evntagnt.dll file is not configured for debug tracing when the SNMP service starts, these two warning events are logged.

RESOLUTION

To stop these events from occuring, add the TraceFileName and the TraceLevel values to the following registry subkey:

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\SNMP_EVENTS\EventLog\Parameters

  • TraceFileName
    Type: REG_SZ
    Value: null (blank)
  • TraceLevel
    Type: REG_DWORD
    Value: 32 (0x20)

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that this article describes. Apply it only to systems that are experiencing this specific problem.

To resolve this problem, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.Windows Server 2003, 32-bit editions
   Date         Time   Version            Size    File name
   --------------------------------------------------------------
   08-Dec-2003  07:04  5.2.3790.110       99,840  Evntagnt.dll     
   06-Dec-2003  01:30                        271  Branches.inf
   08-Dec-2003  07:29                      9,812  Kb832790.cat
   08-Dec-2003  07:10                        354  Updatebr.inf
   08-Dec-2003  07:11                      5,654  Update_rtmqfe.inf
Windows Server 2003, 64-bit editions
   Date         Time   Version            Size    File name          Platform
   --------------------------------------------------------------------------
   08-Dec-2003  05:53  5.2.3790.110      171,520  Evntagnt.dll       IA-64
   06-Dec-2003  00:17                        271  Branches.inf
   08-Dec-2003  06:29                      9,812  Kb832790.cat
   08-Dec-2003  06:15                        354  Updatebr.inf
   08-Dec-2003  06:15                      5,674  Update_rtmqfe.inf

WORKAROUND

To work around this problem, configure the SNMP Service startup type to Disabled. To do this, follow these steps:
  1. Click Start, click Run, type services.msc in the Open box, and then click OK.
  2. In the list of services, double-click SNMP Service.
  3. In the Startup type list, click Disabled, and then click OK.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

Modification Type:MajorLast Reviewed:11/4/2005
Keywords:kbHotfixServer kbQFE kbQFE kbnofix kbEventLog kbBug KB832790 kbAudITPRO