"No such interface supported. (0x80004002)" error message when you use Microsoft Baseline Security Analyzer to download the Mssecure.cab security update (832489)



The information in this article applies to:

  • Microsoft Windows Server 2003, Datacenter Edition
  • Microsoft Windows Server 2003, Enterprise Edition
  • Microsoft Windows 2000 Advanced Server
  • Microsoft Windows 2000 Datacenter Server
  • Microsoft Windows Server 2003, Standard Edition
  • Microsoft Windows Server 2003, Web Edition
  • Microsoft Windows XP Home Edition
  • Microsoft Windows XP Media Center Edition
  • Microsoft Windows XP Professional
  • Microsoft Windows 2000 Professional
  • Microsoft Windows 2000 Server

SYMPTOMS

When you use Microsoft Baseline Security Analyzer (MBSA) to download the Mssecure.cab security update, you receive the following error message:
No such interface supported. (0x80004002)

CAUSE

This problem may occur if download managers (such as Download Express or GetRight) are installed on the computer. Download managers may affect the ability of MBSA to download the Mssecure.cab security update. MBSA does not download the Mssecure.cab security update if MBSA calls the URLDownloadToFile() API from a COM object.

When you install download managers on your computer, protocol namespace handlers are installed in the registry. The MBSA call to the API is not successful if MBSA calls from a COM object when protocol namespace handlers are installed in the registry.

Note To verify whether namespace handlers are installed in the registry, follow these steps:
  1. Click Start, click Run, and then type regedit in the Open box.
  2. On the Edit menu, click Find, type Name-Space Handler in the Find What box, and then click Find Next.
  3. Expand the Name-Space Handler key, and then look for the following key: HKEY_CLASSES_ROOT\PROTOCOLS\Name-Space Handler\http.

WORKAROUND

To work around this problem, remove the download managers that are installed on the computer, and then download the Mssecure.cab security update.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section of this article. The third-party products that this article discusses are manufactured by companies that are independent of Microsoft. Microsoft makes no warranty, implied or otherwise, regarding the performance or reliability of these products.

Modification Type:MinorLast Reviewed:12/27/2005
Keywords:kbprb KB832489 kbAudDeveloper kbAudEndUser kbAudITPRO