The Information Store service may stop responding when Exchange Server 2003 sends an outgoing NDR message (832471)



The information in this article applies to:

  • Microsoft Exchange Server 2003 Enterprise Edition
  • Microsoft Exchange Server 2003 Standard Edition

SYMPTOMS

The Microsoft Exchange Information Store service in Microsoft Exchange Server 2003 stops responding when Exchange 2003 sends an outgoing non-delivery report (NDR). The call stack for the failing thread is similar to the following:

ChildEBP RetAddr  Args to Child              
2deeed44 0041bfb9 00007fff 00000001 040665b0 store!EcFormatMVString8+0x2b
2deeed70 0043f0cd 00007fff 040665a8 2deeedb4 store!EcFormatValue+0x210
2deeeda4 004d0d2f 00007fff 0000000d 00000000 store!EcFormatRow+0xf9
2deeee40 004d08d8 0397b9e6 00000000 04066628 store!EcFormatRecipientRow+0x8ea
2deeefa0 006b73ba 00000001 00000001 00000013 store!ORECIP::EcModifyRow+0x415
2deef238 006bb061 00000001 03e28c30 0406c9e8 store!EcDeliverNDR+0xbc2
2deef408 006cb761 2ec72be8 2ec70a14 00000000 store!EcDeliverReport+0xb6f
2deef694 0054c245 2ec70a14 0100ede0 00000000 store!EcTferInMessage+0x359
2deeff8c 004c1516 00000000 00000000 0390f250 store!FStartTransferIn+0x759
2deeffa8 00678f17 00000000 00000000 2deeffec store!TI::Invoke+0xa4

CAUSE

This problem occurs because of issues that are encountered when the Microsoft Exchange Information Store service processes a non-delivery report.

RESOLUTION

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, Microsoft recommends that you wait for the next Microsoft Exchange Server 2003 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services phone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question. The English version of this hotfix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.

Date         Time   Version      Size   File name
------------------------------------------------------
06-Dec-2003  02:24  6.5.6980.53  5,120  Escprint.dll

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section of this article.

Modification Type:MinorLast Reviewed:10/3/2005
Keywords:kbHotfixServer kbQFE kbExchange2003preSP1fix kbQFE kbfix kbbug KB832471 kbAudITPRO