Folder names do not update when you run Explorer.exe as a published application in a Citrix Metaframe XP session on a Windows 2000-based Terminal server (832427)



The information in this article applies to:

  • Microsoft Windows 2000 Server
  • Microsoft Windows 2000 Professional
  • Microsoft Windows 2000 Advanced Server

SYMPTOMS

When you use Citrix Metaframe XP to connect to a Microsoft Windows 2000-based Terminal server, and Explorer.exe is configured to run as a published application in Citrix, when a folder is renamed on a redirected client drive in the Citrix Metaframe XP session, the folder name does not update dynamically. The folder still displays the old name of the renamed folder.

Note We do not recommend running Explorer.exe as a published application because the published Explorer.exe application runs as a separate process that has restricted access to the desktop.

CAUSE

This problem occurs if you have installed Windows 2000 Service Pack 4 (SP4) or a post-Windows 2000 Service Pack 3 hotfix that has changed the Shell32.dll file.

RESOLUTION

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that this article describes. Apply it only to systems that are experiencing this specific problem.

To resolve this problem, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

Windows 2000 Service Pack 3 or later versions

Restart requirement

You must restart your computer after you apply this hotfix.

Hotfix replacement

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version        Size       File name
   ---------------------------------------------------------
   08-Dec-2003  19:07  5.0.3900.6880  2,357,520  Shell32.dll      

WORKAROUND

To work around this problem, press F5 to manually update the folders in the Citrix Metaframe XP session.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

REFERENCES

The third-party products that this article discusses are manufactured by companies that are independent of Microsoft. Microsoft makes no warranty, implied or otherwise, regarding the performance or reliability of these products. For additional information about how hotfix packages are named, click the following article number to view the article in the Microsoft Knowledge Base:

816915 New file naming schema for Microsoft Windows hotfix packages

For additional information, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft product updates, tools, and add-ons


Modification Type:MinorLast Reviewed:10/26/2005
Keywords:kbHotfixServer kbQFE kbHotfixServer kbQFE kbBug kbfix kbQFE kbWin2000preSP5fix KB832427 kbAudITPRO