Local queue message delivery is very slow and an event 5007 is logged on an Exchange Server 2003 (832037)



The information in this article applies to:

  • Microsoft Exchange Server 2003 Enterprise Edition
  • Microsoft Exchange Server 2003 Standard Edition


SYMPTOMS

The local queue on your Microsoft Exchange Server 2003 server may have many messages, and local delivery of messages may be very slow.

When you view the event log, you may see events that are similar to the following:
Event Type: Error
Event Source: MSExchangeSA
Event Category: General
Event ID: 5007
Date: Date
Time: Time
User: N/A
Computer: Computer_Name
Description: An error occurred during the message tracking decode operation. error from file: Drive_Letter :\df6851\admin\src\libs\rpc\rwlog.cxx line: 517. <<0xc0070005 - Access is denied.>>

CAUSE

This problem may occur if the Mad.exe process stops responding (hangs) because of access issues on the message tracking log location.

WORKAROUND

To work around this problem, follow these steps:
  1. Start Windows Explorer.
  2. Locate the Server_Name.log file. The default location of the Server_Name.log file is C:\Program Files\Exchsrvr\Server_Name.log.
  3. Right-click Server_Name.log, and then click Properties.
  4. Click the Security tab.
  5. In the Name list, click SYSTEM.
  6. In the Permissions list, click to select the Allow check box next to Full Control, and then click OK.
Note The Microsoft Exchange System Attendant service (MSExchangeSA) runs under the local system account. This local system account is named SYSTEM on the Security tab of the Exchsrvr Properties dialog box for the C:\Program Files\Exchsrvr folder. By default, SYSTEM is granted Full Control permissions for everything in the C:\Program Files\Exchsrvr folder, including the default message tracking log location. If the message tracking log folder is moved to a different location, you must make sure that the SYSTEM local system account is granted Full Control permissions over this new log location.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

Modification Type:MinorLast Reviewed:11/7/2005
Keywords:kbprb KB832037 kbAudITPRO