BUG: The Data Warehouse Import Wizard appears to hang when the Profile Data Import DTS task runs (832007)



The information in this article applies to:

  • Microsoft Commerce Server 2002, Service Pack 3 (SP3)

SYMPTOMS

In Microsoft Commerce Server 2002, the Data Warehouse Import Wizard appears to stop responding (hang) while the Profile Data Import DTS task runs. You do not receive an error message but the process does not appear to complete for a while.

CAUSE

By default, the Data Warehouse Import Wizard uses a start date of January 1, 2000 (01/01/2000) and a query interval of 15 minutes. If you import profile data by using these values, the Data Warehouse Import Wizard will try to read the data from 01/01/2000 00:00-00:15, 01/01/2000 00:15 - 00:30, and so on.

RESOLUTION

To resolve this problem and to improve profile data import speed, configure the start date value and the query interval value. Change the start date and the query interval to values that are appropriate to the data that you want to import.

STATUS

Microsoft has confirmed that this is a bug in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

To successfully import data by using the Data Warehouse Import Wizard, follow these steps:
  1. Create a package in the Data Warehouse Import Wizard.
  2. Save the package. Do not run the package directly.
  3. In Microsoft SQL Server Enterprise Manager, open the package.
  4. Modify the properties of the Profile DTS Task that is in the package. The value of the Import start date property depends on the data that you have. Set the value of the Query interval property to 0 (zero).
  5. Save, and then execute the package.
For more information, visit the following Microsoft Developer Network (MSDN) Web site:

Modification Type:MajorLast Reviewed:6/18/2004
Keywords:kbtshoot kbbug KB832007 kbAudDeveloper