You receive an error message when you try to print to a shared network printer in a terminal server session (831754)



The information in this article applies to:

  • Microsoft Windows Server 2003, Enterprise Edition
  • Microsoft Windows Server 2003, Standard Edition
  • Microsoft Windows 2000 Server
  • Microsoft Windows 2000 Professional
  • Microsoft Windows 2000 Advanced Server

SYMPTOMS

When you are connected to a terminal server session on a Microsoft Windows 2000-based computer or a Microsoft Windows Server 2003-based computer, and you try to print from any program to a shared network printer, you may receive an error message that is similar to one of the following:
No printers are installed. To install a printer, point to settings on the Windows Start Menu, click Printer, and then double-click Add Printer. Follow the instructions in the wizard.
Current printer is unavailable. Select another printer.
Before you can print, you need to select a printer. If you need to install a printer, either double-click the Add Printer icon or click the Find Printer button located on the general tab of this dialog.
Error messages vary from program to program.

After you receive one of these error messages and then click OK, the Printer dialog box may open. If you select the same printer that caused the error message, the Print and Apply buttons are not available, and you cannot print. If you select a different printer, you may be able to print.

CAUSE

This problem may occur if another user logs on to the terminal server, and the user has a later version of the same printer driver installed on their computer. When the print spooler detects the new driver on the terminal server, the spooler creates a new binary data file for the later version of the printer driver. When you try to print from a program in your terminal server session, you cannot access the new binary data file because the earlier version of the printer driver is installed on your computer.

Binary data files are temporary files that the Universal Printer Driver (Unidrv) creates after it parses information that is contained in minidriver text files. The Universal Printer Driver (Unidrv) is the standard printer driver that Microsoft uses for non-PostScript printers. Unidrv binary data files have a .bud file name extension.

RESOLUTION

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Windows Server 2003 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services phone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

No prerequisites are required.

Restart Requirement

You must restart your computer after you apply this hotfix.

Hotfix Replacement Information

This hotfix does not replace any other hotfixes.

File Information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.

Windows 2000

   Date         Time   Version            Size    File name
   --------------------------------------------------------------
   20-Nov-2003  22:59  5.0.2195.6824      42,256  Basesrv.dll      
   21-Sep-2003  00:45  5.0.2195.6824     236,304  Cmd.exe          
   20-Nov-2003  22:59  0.2.0.1           138,000  Faxui.dll        
   20-Nov-2003  22:59  5.0.2195.6824     222,992  Gdi32.dll        
   20-Nov-2003  22:59  5.0.2195.6867     711,440  Kernel32.dll     
   20-Nov-2003  22:59  5.0.2195.6876     252,688  Localspl.dll     
   20-Nov-2003  22:59  5.0.2195.6824      54,032  Mpr.dll          
   20-Nov-2003  22:59  5.0.2195.6876     334,096  Msgina.dll       
   20-Nov-2003  22:59  5.0.2195.6824      90,232  Rdpwd.sys
   06-Nov-2003  22:29  5.0.2195.6870   5,847,552  Sp3res.dll       
   20-Nov-2003  22:59  5.0.2195.6876      80,144  Spoolss.dll      
   20-Nov-2003  22:59  5.0.2195.6869     380,176  User32.dll       
   20-Nov-2003  22:59  5.0.2195.6871     389,392  Userenv.dll      
   31-Oct-2003  03:02  5.0.2195.6869   1,628,816  Win32k.sys
   20-Nov-2003  22:59  5.0.2195.6824      87,312  Win32spl.dll     
   11-Nov-2003  00:29  5.0.2195.6873     182,032  Winlogon.exe     
   20-Nov-2003  22:59  5.0.2195.6873     243,984  Winsrv.dll       
   20-Nov-2003  22:59  5.0.2195.6867     711,440  Kernel32.dll     
   31-Oct-2003  03:02  5.0.2195.6869   1,628,816  Win32k.sys
   20-Nov-2003  22:59  5.0.2195.6873     243,984  Winsrv.dll       
   20-Nov-2003  23:08                     12,866  Kb831754.cat

Windows Server 2003, 32-bit editions

   Date         Time   Version            Size    File name
   --------------------------------------------------------------
   30-Sep-2004  23:28  5.2.3790.220      312,320  Localspl.dll     
   30-Sep-2004  23:28  5.2.3790.212       81,408  Spoolss.dll 

Windows Server 2003, 64-bit editions

   Date         Time   Version            Size    File name      Platform
   ----------------------------------------------------------------------
   30-Sep-2004  23:32  5.2.3790.220      860,160  Localspl.dll   IA-64
   30-Sep-2004  23:32  5.2.3790.212      233,984  Spoolss.dll    IA-64

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For additional information about how hotfix packages are named, click the following article number to view the article in the Microsoft Knowledge Base:

816915 New file naming schema for Microsoft Windows software update packages

For additional information, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates


Modification Type:MinorLast Reviewed:10/28/2005
Keywords:kbHotfixServer kbQFE kbBug kbfix kbQFE kbWin2000preSP5fix KB831754 kbAudITPRO