Computers with IP addresses that are more than 14 characters are not correctly discovered in Systems Management Server 2003 (831737)



The information in this article applies to:

  • Microsoft Systems Management Server 2003

Some discovered computers are not assigned to the Microsoft Systems Management Server (SMS) 2003 site. When you view the IP address of discovered computers in the SMS Administrator Console, the IP address may be empty or truncated. Consider the following configuration:

Your site boundary is set to 158.226.158.96.
Your client computers have the following IP addresses:

Client 1: 158.226.158.98
Client 2: 158.226.158.99
Client 3: 158.226.158.100


After Active Directory directory service System Discovery is completed, the clients appear with the following assignments:

Client 1: YES
Client 2: YES
Client 3: NO


The Discovery Data IP address of Client 3 is 158.226.158.10 in the SMS Administrator Console.

CAUSE

The Active Directory discovery method of SMS 2003 captures only 14 characters of a standard 15-character IP address.

RESOLUTION

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next SMS 2003 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

No prerequisites are required.

Restart required

You do not have to restart your computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version            Size    File name
   --------------------------------------------------------------
   07-Nov-2003  17:24                     11,260  Filemap.ini
   07-Nov-2003  17:24  2.0.6.0           353,744  Smsupdate.exe    
   07-Nov-2003  17:24  2.50.2726.100     110,592  Adsource.dll     
   07-Nov-2003  17:24  2.0.1493.5011     855,312  Preinst.exe  

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For additional information, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates


Modification Type:MinorLast Reviewed:10/27/2005
Keywords:kbHotfixServer kbQFE kbDiscovery kbInventory kbCollections kbsmsAdmin kbQFE kbfix kbBug KB831737 kbAudITPRO