Event ID 4100 or Event ID 4356 is logged in the application event log of Advanced Clients in Systems Management Server 2003 (831648)



The information in this article applies to:

  • Microsoft Systems Management Server 2003

SYMPTOMS

On client computers that are running Microsoft Systems Management Server (SMS) 2003 Advanced Client, the following event may be logged the application event log:Event Type: Warning
Event Source: EventSystem
Event Category: Firing Agent
Event ID: 4100
Date: 8/28/2003
Time: 5:22:13 AM
User: N/A

Description: The COM+ Event System failed to create an instance of the subscriber {C2F23AE4-82D8-456F-A4AF-A2655D8CA726}. CoCreateInstanceEx returned HRESULT 8000401A.

On client computers that are running Microsoft Windows Server 2003 or Microsoft Windows XP, the following event may be logged in the application event log:Event Type: Warning
Event Source: EventSystem
Event Category: Firing Agent
Event ID: 4356
Date: 8/28/2003
Time: 5:22:13 AM
User: N/A

Description: The COM+ Event System failed to create an instance of the subscriber {C2F23AE4-82D8-456F-A4AF-A2655D8CA726}. StandardCreateInstance returned HRESULT 8000401A.

CAUSE

This problem occurs if the Patch UI Monitor component tries to call the client user interface (UI) when no user is logged on.

RESOLUTION

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Systems Management Server 2003 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

No prerequisites are required.

Restart requirement

You do not have to restart your computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version            Size    File name
   --------------------------------------------------------------
   04-Dec-2003  18:23                     11,281  Filemap.ini
   04-Dec-2003  18:23  2.0.6.3           354,152  Smsupdate.exe    
   04-Dec-2003  18:23  2000.80.194.0     274,489  Ntwdblib.dll     
   04-Dec-2003  18:23  2.50.2726.104     111,104  Patchuimonitor.dll  
   04-Dec-2003  18:23  2.0.1493.5011     855,312  Preinst.exe      
   04-Dec-2003  18:23                    248,320  Sms2003ac-kb831648-x86.msp

Installation information

To apply this hotfix, follow these steps. Apply this hotfix to all Advanced Clients in your hierarchy. Depending upon your SMS hierarchy configuration, you may want to complete these steps on primary and secondary site servers so that you target every Advanced Client in your environment with this software distribution.
  1. Create a folder in a location that is accessible to your SMS site servers.
  2. Copy the SMS2003-RTM-KB831648-X86-ENU.exe update file to the new folder.
  3. Log on to the site server as an administrator.
  4. Quit the SMS Administrator Console if it is running.
  5. Run the SMS2003-RTM-KB831648-X86-ENU.exe update file, and then follow the instructions in the wizard.
  6. When prompted by the installation wizard, click Yes, I want to create a package and program now. Make sure to review the Applying hotfixes to SMS Advanced Clients information later in the installation wizard.
  7. Start the SMS Administrator Console.
  8. Open the Site Hierarchy\your site\Site Settings\Client Agents tree, where your site is the name of your SMS site.
  9. Right-click Software Inventory Client Agent, and then click Properties.
  10. Make sure that Enable software inventory on clients is turned on.
  11. On the Inventory Collection tab, click the button that has the yellow star.
  12. In the Name text box, type PatchUIMonitor.dll, click OK, two times.
  13. Allow a minimum of two days for software inventory to complete on all client computers.

    Important You must allow software inventory to complete before you continue to step 14.
  14. After software inventory is completed on all clients, right-click the Collection node in the SMS Administrator Console, point to New, and then click Collection.
  15. Type a name for the collection, for example Advanced Clients that require Q831648.
  16. On the Membership Rules tab, click the yellow database button to open Query Rule Properties.
  17. Type a name for the query, and then click Edit Query Statement.
  18. Click Show Query Language.
  19. Delete the existing query statement, paste the following query in the Query statement area, and then click OK three times:

    select SMS_G_System_COMPUTER_SYSTEM.Name, SMS_G_System_SoftwareFile.FileName, SMS_G_System_SoftwareFile.FileVersion, SMS_G_System_SoftwareFile.FileDescription, SMS_G_System_SoftwareFile.FileSize, SMS_G_System_SoftwareFile.FilePath from SMS_R_System inner join SMS_G_System_COMPUTER_SYSTEM on SMS_G_System_COMPUTER_SYSTEM.ResourceID = SMS_R_System.ResourceId inner join SMS_G_System_SoftwareFile on SMS_G_System_SoftwareFile.ResourceID = SMS_R_System.ResourceId where SMS_G_System_SoftwareFile.FileName = "PatchUIMonitor.dll" and SMS_G_System_SoftwareFile.FileVersion < "2.50.2726.0104"
  20. In the SMS Administrator Console, expand the Packages node, locate and expand the KB831648 - Advanced Client Hotfix package, and then click Distribution Points.
  21. Right-click Distribution Points, and click New, and then click Distribution Points.
  22. In the New Distribution Points Wizard, click Next, click all the Distribution Points where you want to copy the package, and then click Finish.
  23. Locate and right-click the Advertisements node, point to New, and then click Advertisement.
  24. In the Name text box, type a name for the advertisement.
  25. In the Package list, click KB831648 - Advanced Client Hotfix.
  26. In the Program list, click KB 831648 - Advanced Client Patch Install.
  27. Click Browse, click the collection that you created in step 14, and then click OK two times.
Important Advertisement status for this hotfix may be reported incorrectly if you have distributed additional Advanced client hotfixes.

For additional information, click the following article number to view the article in the Microsoft Knowledge Base:

840864 Incorrect status is returned after you distribute an update for the Advanced Client in Systems Management Server 2003


STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For additional information about standard terminology used to describe software updates, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates


Modification Type:MinorLast Reviewed:4/14/2006
Keywords:kbQFE kbHotfixServer kbClient kbSMSTopazFix kbEventLog kbEvent kbSoftwareDist kbfix kbBug KB831648 kbAudITPRO