The Visual FoxPro OLE DB Provider raises error 2066 during moderate to heavy multi-user load (831462)



The information in this article applies to:

  • Microsoft Visual FoxPro 8.0
  • Microsoft Visual FoxPro 8.0 SP1

SYMPTOMS

The Microsoft Visual FoxPro OLE DB Provider raises the following error message during moderate to heavy multi-user load:
error 2066 (Index file is corrupt. Please rebuild it.)

CAUSE

This error indicates that the index tag is corrupted. During multi-user load this error can occur but may not be valid. This behavior occurs when the table has been updated by a user. Because the 5-second refresh interval has not expired, the index in memory on the other client computer is not current. The other client computer recognizes this condition and the error is raised.

WORKAROUND

A user can work around this problem by calling the sys(1104) function or by setting the refresh interval to 1,1 in Visual FoxPro on the client computer. These options are not available from the Visual FoxPro OLE DB Provider.

RESOLUTION

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Visual FoxPro 8.0 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question. The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time    Version     Size     File name    
   -------------------------------------------------------
   29-Oct-2003  20:38  8.0.0.3117      3,059,712  Vfpoledb.dll     
   
  

STATUS

Microsoft has confirmed that this is a bug in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For additional information, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates


Modification Type:MinorLast Reviewed:10/7/2005
Keywords:kbQFE KB831462 kbAudDeveloper