The PivotTable service setup fails and you receive the error message "Target language is not supported for upgrade." (831370)



The information in this article applies to:

  • Microsoft SQL Server 2000 Analysis Services

SYMPTOMS

When you run the PTSFull.exe file or the PTSLite.exe file to install Microsoft SQL Server 2000 PivotTable Service on your computer, you may receive the following error message:

Target language is not supported for upgrade.

CAUSE

The problem may occur if one or more of the following conditions are true:
  • The computer that has Microsoft SQL Server 2000 PivotTable Service installed is running a version of Microsoft Internet Explorer that is earlier than Microsoft Internet Explorer version 5.0.
  • The Msolapr.dll file is not the English version of the file and the Msolapr.dll file language is different from the SQL Server 2000 PivotTable Service setup language.
  • The Msolap80.dll file that is installed on the computer and the language that is stored in the HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Uninstall key for the product is not English, and the language of the Msolap80.dll file is different from the language of the SQL Server 2000 PivotTable Service setup.

    Note You can find the Msolap.dll, the Msolap80.dll, or the Msolapdr.dll files in the Drive name\Program files\Common files\System\Ole DB folder.

WORKAROUND

Here are two methods that you can use to work around the problem.

Method 1

  1. Make sure that Microsoft Internet Explorer version 5.0 or later is installed on your computer.
  2. Unregister the Msolap.dll file or the Msolap80.dll file. To unregister the Msolap.dll file, run the following command at the command prompt:

    REGSVR32 /u Drive: Path for the Msolap.dll file

    To unregister the Msolap80.dll file, run the following command at the command prompt:

    REGSVR32 /u Drive: Path for the Msolap80.dll

    Note You can find the PTSFull file and the PTSLite file in the \Msolap\Install\PTS folder of the Microsoft SQL Server 2000 setup folder.
  3. Delete the Msolap.dll file or the Msolap80.dll file.
  4. Run the PTSFull setup file or the PTSLite setup file.

Method 2

Run the Microsoft SQL Server 2000 Analysis Services setup and only install the client components.

Note The client components of SQL Server 2000 Analysis Services will install Microsoft Data Access Components (MDAC) version 2.6 and Microsoft SQL Server 2000 PivotTable Service. The files that are installed during the setup of the client components may be different from those installed by PTSFull or PTSLite.

MORE INFORMATION

Make sure that you install PTSFull or PTSLite on your computer before you install any third party software that may affect .dll files such as Msolap.dll, Msolap80.dll, or Msolapr.dll.

When you run the PTSFull or the PTSLite file, the setup initially detects whether the Msolap80.dll and the Msolap.dll files are installed on your computer. If products such as Microsoft SQL Server 7.0 OLAP Services client and Microsoft Office 2000 are installed on your computer, the Msolap.dll file will be on your computer. If one or more of the products such as SQL Server 2000 Analysis Services client components, PTSFull, PTSLite, Microsoft Office XP, and Microsoft Office 2003 are installed on your computer, the Msolap80.dll file will be on your computer.

REFERENCES

For additional information about PivotTable Service, visit the following Microsoft Web site:

http://msdn.microsoft.com/library/default.asp?url=/library/en-us/olapdmpr/pt_intro_49wl.asp

For additional information about the Regsvr32 command, click the following article number to view the article in the Microsoft Knowledge Base:

249873 Explanation of Regsvr32 Usage and Error Messages




Modification Type:MajorLast Reviewed:12/9/2003
Keywords:kbPivotTable kbDLL kbsetup kberrmsg kbprb KB831370 kbAudDeveloper