A ListView item remains selected after you cancel a drag-and-drop operation in Microsoft Management Console 2.0 (831367)



The information in this article applies to:

  • Microsoft Management Console 2.0, when used with:
    • the operating system: Microsoft Windows Server 2003
    • the operating system: Microsoft Windows XP SP1
    • the operating system: Microsoft Windows XP Home Edition
    • the operating system: Microsoft Windows XP Professional

SYMPTOMS

You can add a snap-in that contains a ListView control in Microsoft Management Console (MMC) 2.0. You can then try to perform a drag-and-drop operation that involves the items in the ListView control. However, if you press the ESC key to cancel the drag-and-drop operation, the selected ListView item may remain selected.

Note You notice this behavior on a computer that runs Microsoft Windows XP only if you install Windows XP Service Pack 1 (SP1).

CAUSE

MMC generates an LVM_GETNEXTITEM ListView message to update the display of the ListView control after you cancel the drag-and-drop operation. However, if the style of a ListView control is set to LVS_OWNERDATA, the event handler for the LVM_GETNEXTITEM ListView message cannot enumerate ListView items whose state is set to LVNI_DROPHILITED. The LVNI_DROPHILITED state corresponds to a selected ListView item. Therefore, the LVNI_DROPHILITED state of such ListView items is not reset, and the items remain selected. This problem occurs with ListView items whose state is set to any state other than LVNI_FOCUSED or LVNI_SELECTED.

RESOLUTION

Service pack information

Windows XP

To resolve this problem, obtain the latest service pack for Microsoft Windows XP. For additional information, click the following article number to view the article in the Microsoft Knowledge Base:

322389 How to obtain the latest Windows XP service pack

Hotfix information

Windows Server 2003

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Windows Server 2003 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Restart requirement

If you quit all running instances of MMC before you install this hotfix, you do not have to restart your computer after you install the hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

Hotfix file information

The English version of this hotfix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel. Windows Server 2003 x86
   Date         Time   Version       Size     File name
   ----------------------------------------------------
   17-Nov-2003  14:41  5.2.3790.104  780,800  Mmc.exe
Windows Server 2003 IA-64
   Date         Time   Version       Size       File name
   ------------------------------------------------------
   17-Nov-2003  07:46  5.2.3790.104  2,598,400  Mmc.exe 
   17-Nov-2003  11:41  5.2.3790.104    780,800  Wmmc.exe

Windows XP

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Windows XP service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Restart requirement

If you quit all running instances of MMC before you install this hotfix, you do not have to restart your computer after you install the hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

Hotfix file information

The English version of this hotfix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel. Windows XP x86
   Date         Time   Version        Size     File name
   -----------------------------------------------------
   10-Nov-2003  02:18  5.1.2600.1319  765,952  Mmc.exe
Windows XP IA-64
   Date         Time   Version        Size       File name
   -------------------------------------------------------
   08-Nov-2003  23:01  5.1.2600.1319  2,907,136  mmc.exe 
   09-Nov-2003  23:18  5.1.2600.1319    765,952  Wmmc.exe

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section of this article.

Windows XP

This problem was first corrected in Microsoft Windows XP Service Pack 2.

MORE INFORMATION

For additional information, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the Standard Terminology That Is Used to Describe Microsoft Software Updates

For more information, visit the following Microsoft Developer Network (MSDN) Web sites:

Modification Type:MinorLast Reviewed:10/25/2005
Keywords:kbHotfixServer kbQFE kbQFE kbWinXPsp2fix kbWinServ2003preSP1fix kbWinXPpreSP2fix kbBug kbState kbSnapIn kbhighlight kbDragDrop kbListView kbfix KB831367 kbAudDeveloper