"\WINNT\SYSTEM32\CONFIG\SYSTEM is corrupt" error message when you try to restart your Exchange 2000 server or your Exchange Server 2003 (831260)



The information in this article applies to:

  • Microsoft Exchange Server 2003 Enterprise Edition
  • Microsoft Exchange Server 2003 Standard Edition
  • Microsoft Exchange 2000 Server
  • Microsoft Exchange 2000 Enterprise Server

Important This article contains information about modifying the registry. Before you modify the registry, make sure to back it up and make sure that you understand how to restore the registry if a problem occurs. For information about how to back up, restore, and edit the registry, click the following article number to view the article in the Microsoft Knowledge Base:

256986 Description of the Microsoft Windows Registry

SYMPTOMS

When you restart a computer that is running Microsoft Exchange 2000 Server or Microsoft Exchange Server 2003, you receive the following error messages:
Windows could not start because the following file is missing or corrupt: \WINNT\SYSTEM32\CONFIG\SYSTEM
Windows could not start because the following file is missing or corrupt: \WINNT\SYSTEM32\CONFIG\SYSTEM.ced

CAUSE

This problem occurs because of a condition in Exchange Server that may cause the System hive to unexpectedly grow. The System hive is limited to approximately 10.3 MB. This is because the System hive and the Microsoft Windows kernel must be less than 16 MB when Windows starts.

RESOLUTION

To resolve this problem, you must first recover from the registry condition that kept your computer from starting. After you start your computer, install the hotfix that is described in this article to resolve the problem that caused your System hive to grow beyond the 10.3 MB limit.

Restore or repair the registry

To recover from the registry condition that is described in this article, use one of the following methods:
  • Restore your registry from a working backup. To restore the registry, you must have a previously-created backup of the registry. For additional information about how to restore the registry, click the following article number to view the article in the Microsoft Knowledge Base:

    322755 How to back up, edit, and restore the registry in Windows 2000

  • Use the Windows 2000 Registry Repair Utility (Chkreg.exe) to repair the registry. Use this utility if you do not have a backup of your registry.

    For additional information about how to obtain and use the Windows 2000 Registry Repair Utility, visit the following Microsoft Web site:

Exchange Server 2003

Service pack information

To resolve this problem, obtain the latest service pack for Microoft Exchange Server 2003. For more information, click the following article number to view the article in the Microsoft Knowledge Base:

836993 How to obtain the latest service packs for Exchange Server 2003

Exchange 2000 Server

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Exchange 2000 Server service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.
Component: System Attendant

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.

Date         Time   Version            Size    File name
--------------------------------------------------------------
23-Dec-2003  03:55  6.0.6552.0      4,370,432  Adcadmin.dll     
23-Dec-2003  03:55  6.0.6552.0         69,632  Ccmproxy.dll     
23-Dec-2003  03:55  6.0.6552.0      2,109,440  Cdoexm.dll       
23-Dec-2003  03:55  6.0.6552.0      8,470,528  Exadmin.dll      
23-Dec-2003  03:55  6.0.6552.0      3,850,240  Excluadm.dll     
23-Dec-2003  03:56  6.0.6552.0      1,867,776  Exmgmt.exe       
23-Dec-2003  03:42  6.0.6552.0        720,896  Exsp.dll         
23-Dec-2003  03:56  6.0.6552.0      1,347,584  Exwmi.dll        
23-Dec-2003  03:56  6.0.6552.0         73,728  Inproxy.dll      
23-Dec-2003  03:56  6.0.6552.0      2,973,696  Mad.exe          
23-Dec-2003  03:56  6.0.6552.0        811,008  Madmsg.dll       
23-Dec-2003  03:55  6.0.6552.0      4,698,112  Maildsmx.dll     
23-Dec-2003  03:27  6.0.6552.0         57,344  Oabgen.dll       
23-Dec-2003  03:56  6.0.6552.0         77,824  Pcproxy.dll      
23-Dec-2003  03:56  6.0.6552.0         94,208  X400prox.dll

Note Because of file dependencies, this hotfix requires Exchange 2000 Server Service Pack 3 (SP3). For additional information, click the following article number to view the article in the Microsoft Knowledge Base:

301378 How to obtain the latest Exchange 2000 Server service pack

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.
This problem was first corrected in Microsoft Exchange Server 2003 Service Pack 2.

MORE INFORMATION

Warning If you use Registry Editor incorrectly, you may cause serious problems that may require you to reinstall your operating system. Microsoft cannot guarantee that you can solve problems that result from using Registry Editor incorrectly. Use Registry Editor at your own risk.
After you apply this hotfix, you must add the following subkey to the registry:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\MSExchangeSA\LegacyCodeExecutionLevel

To add this subkey, follow these steps:
  1. Start Registry Editor (regedit.exe).
  2. Locate and click the following registry subkey:

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\MSExchangeSA

  3. On the Edit menu, point to New, and then click DWORD Value. Add the following value information to this subkey:

    Value name: LegacyCodeExecutionLevel
    Value type: DWORD

    The registry subkey should now appear as:

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\MSExchangeSA\LegacyCodeExecutionLevel

You can set the value of this subkey to any one of the following values:
  • 0: Use this setting if you do not want to exclude anything. All the code will be run.
  • 1: Use this setting if you want to exclude the legacy code that is safe to exclude, but include the code that can have high destabilization impact.
  • 2: Use this setting if you want to exclude all the legacy code.

    Note This setting is a high risk setting. If you set this value to 2, the Exchange System Attendant (MAD) does not apply any of the security policies to the registry.

Modification Type:MajorLast Reviewed:10/20/2005
Keywords:kbHotfixServer kberrmsg kbQFE kbfix kbExchange2000preSP4fix kbbug KB831260 kbAudITPRO