You cannot rename or copy a file when you connect to your workspace by using Web folders in SharePoint Portal Server 2001 (831199)



The information in this article applies to:

  • Microsoft SharePoint Portal Server 2001

SYMPTOMS

After you install the client components of Microsoft SharePoint Portal Server 2001 on your computer, you may find that you cannot copy or rename a file in a folder in the workspace. This problem occurs when you connect to the workspace by using a network place shortcut that you created by using Web Distributed Authoring and Versioning (WebDAV). When you rename a file, you receive an error message that is similar to the following:
Unable to rename URL of Folder

CAUSE

This problem may occur if both the following conditions are true:
  • The name of the file that you want to rename or copy is different from the value of the DAV:displayname property of the file.
  • You are using an Apache Web server.
In this situation, an incorrect URL is sent to the server when you rename or copy the file by using Web folders.

RESOLUTION

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next SharePoint Portal Server 2001 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.
The English version of this hotfix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.

Date         Time   Version         Size       File name
-----------------------------------------------------------
14-Nov-2003  12:27  10.145.6011.34  1,327,104  Msonsext.dll

Note This hotfix requires Microsoft SharePoint Portal Server 2001 Service Pack 2a (SP2a).

WORKAROUND

To work around this problem, connect to the workspace by using Microsoft Internet Explorer, and then rename or copy the file.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section of this article.

MORE INFORMATION

For more information about SharePoint Portal Server 2001, visit the following Microsoft Web site:

Modification Type:MajorLast Reviewed:4/7/2006
Keywords:kbQFE KBHotfixServer kbSharePtPortalSvr2001preSP3fix kbfix kbBug KB831199 kbAudITPRO