Software packages do not install on Systems Management Server 2003 clients (831198)



The information in this article applies to:

  • Microsoft Systems Management Server 2003

Important This article contains information about modifying the registry. Before you modify the registry, make sure to back it up and make sure that you understand how to restore the registry if a problem occurs. For information about how to back up, restore, and edit the registry, click the following article number to view the article in the Microsoft Knowledge Base:

256986 Description of the Microsoft Windows Registry

SYMPTOMS

Microsoft Systems Management Server (SMS) 2003 may not be able to install software on a client when the package is run by a user who does not have sufficent rights or a computer that does not have sufficient rights. When this problem occurs, SMS cannot update the Windows Installer source list. Additionally, following may be logged in the SrcUpdateMgr.log file:
Retrying DoUpdateSourceListAll task 
Product {000C1109-0000-0000-C000-000000012346} is installed for user domain\account
Adding 2 local DPs and 0 remote DPs for product {000C1109-0000-0000-C000-000000012346}
MsiSourceListClearAll failed for product {000C1109-0000-0000-C000-000000012346}, user domain\account, error 80070005
Failed source list update for product {000C1109-0000-0000-C000-000000012346}, error 80070005
DoUpdateSourceListAll task failed, error code 80070005
Source list update task failed, will be retried after 3600 seconds

CAUSE

This problem may occur if you apply the Always install with elevated privileges Microsoft Windows Installer Group Policy setting for a user who does not have sufficient rights or for a computer that does not have sufficient rights.

RESOLUTION

Important Advertisement status for this hotfix may be reported incorrectly if you have distributed additional Advanced Client hotfixes. For more information, view the following article in the Microsoft Knowledge Base:

840864 Incorrect status is returned after you distribute an update for the Advanced Client in Systems Management Server 2003


Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next SMS 2003 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

No prerequisites are required.

Restart requirement

You do not have to restart your computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version	      Size     File name
-------------------------------------------------------------------------------
09-Dec-2003  21:26  2.50.2726.101     927,976  Sms2003-rtm-kb831198-x86-enu.exe
After the fix is installed, the following files will have the listed attributes or later:
Date         Time   Version           Size     File name
-------------------------------------------------------------------------
09-Dec-2003  16:46                     11,595  Filemap.ini
09-Dec-2003  16:46  2.0.6.3           354,152  Smsupdate.exe    
09-Dec-2003  16:46  2000.80.194.0     274,489  Ntwdblib.dll     
09-Dec-2003  16:46  2.0.1493.5011     855,312  Preinst.exe      
09-Dec-2003  16:46                    264,704  Sms2003ac-kb831198-x86.msp
09-Dec-2003  16:46  2.50.2726.101     170,496  Srcupdatemgr.dll 

MORE INFORMATION

Warning Serious problems might occur if you modify the registry incorrectly by using Registry Editor or by using another method. These problems might require that you reinstall your operating system. Microsoft cannot guarantee that these problems can be solved. Modify the registry at your own risk.
When the Always install with elevated privileges Windows Installer Group Policy setting is applied, users who do not have sufficient user rights do cannot update the Windows Installer source list to install the software package. To determine if the policy is applied, follow these steps:
  1. Log on to the client computer as a member of the Administrators group.
  2. Click Start, click Run, type regedit and then click OK.
  3. Locate the HKEY_LOCAL_MACHINE\Software\Policies\Microsoft\Windows\Installer key.
  4. The policy is turned on if the AlwaysInstallEnabled entry is set to 1. To turn off AlwaysInstallEnabled, change the value to 0.

    Note The default value is 0 (off).
For more information, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

Modification Type:MinorLast Reviewed:4/14/2006
Keywords:kbQFE kbHotfixServer kbSoftwareDist kbPackage kbSMSTopazFix kbSecurity kbfix kbBug KB831198 kbAudITPRO