After you reactivate an existing sales process in Microsoft Business Solutions CRM Workflow 1.0, the sales process activities are missing (831181)



The information in this article applies to:

  • Microsoft Business Solutions CRM 1.0
  • Microsoft Business Solutions CRM Sales, when used with:
    • Microsoft Business Solutions CRM 1.0

SYMPTOMS


After you deactivate and then reactivate an existing sales process for the Opportunity object in Microsoft Business Solutions CRM Workflow 1.0, the sales process activities are missing when you open an existing Opportunity object.

CAUSE

When you deactivate a sales process in Workflow Manager, the process type code for this sales process is updated. The Microsoft CRM Workflow Service uses this value to decide which processes are ready to be deleted. This prevents the sales process stages for existing records from appearing in Microsoft CRM.

RESOLUTION

The Microsoft CRM fix for this problem is part of a cumulative package that is described in the following Microsoft Knowledge Base article: For additional information, click the following article number to view the article in the Microsoft Knowledge Base:

834572 Microsoft Business Solutions CRM hotfix rollup for KB 831181, KB 831189, and KB 834548

MORE INFORMATION

Steps to reproduce the behavior

Create a new sales process in Workflow Manager.

  1. Click Start, point to All Programs, point to Microsoft CRM, and then point to Workflow Manager in Microsoft CRM Workflow Manager for the Opportunity object. In this example, the sales process task activity must be set to Wait Condition.
  2. In the Workflow Manager Logon window, in the Target Microsoft CRM server box, enter the name of the target Microsoft CRM server, and then click OK.
  3. The Microsoft CRM Workflow Manager window will open. In the Object list, click Opportunity. In the View list, click Sales Process.
  4. On the File menu, click New.
  5. In the Create a Sales Process window, enter the required information in the Rule Name box and in the Rule Description box, and then click Create in the Select the event list.
  6. Click Next.

Create the details of a sales process for the Opportunity object.

Now you are ready to enter the details of the sales process. In this example, the sales process task activity must be set to Wait Condition.
  1. In the Create a Sales Process window, click Insert Stage. Enter the required information in the Sales Stage box, in the Description box, and in the Probability box, and then click Next.
  2. For the stage that you just created, click Add actions here.
  3. On the Common Tasks side menu, click Insert Action, and then click Create Activity.
  4. Enter the required information in the Subject box, and then click Task in theType list.
  5. Click OK to return to the Create a Sales Process window.
  6. You will now see the task activity that you created for the sales process. Click Add conditions here, and then click Insert Condition from the Common Tasks side menu.
  7. In the Activity list, click to select the task activity that you created earlier, and in the is list, click Completed.
  8. Click OK to return to the Create a Sales Process window.
  9. Click Save to close the Create a Sales Process window.
  10. Right-click the rule that you created, and then click Activate.
  11. Close Workflow Manager.

Create an Opportunity object that has a task activity in Microsoft CRM.

Creating an Opportunity object that has a completed task activity will start the sales process that you created earlier.
  1. Open Microsoft CRM, click Sales, click Opportunity, and then click New Opportunity.
  2. Enter all required fields for the Opportunity object, and then click Save.
  3. Click Activities from the side menu, and then click New Activity.
  4. In the New Activity window, select Task as the type of activity.
  5. Enter all required fields for the activity and then click Save.
  6. When the activity is saved, click Actions from the side menu, and then click Close. In the Task Close Confirmation window, click to select Completed from the Status list, and then click OK.
  7. Click Close to close the Activity window.
You can now view the sales process for the Opportunity object that you created. In the window for the Opportunity object that you created earlier, click the Activities side menu, and then click the Sales Process tab. You should see the sales process stage.

Deactivate and then reactivate the sales process.

Deactivating and then reactivating the sales process will remove the sales process stages that you saw earlier.
  1. Open the Opportunity object sales process that you created in Workflow Manager when you followed steps 1-3 in the "Create a new sales process in Workflow Manager" section.
  2. Right-click the sales process that you created, and then click Deactivate. Wait several seconds, right-click the sales process that you created, and then click Activate.
  3. Open the activity that you created for the Opportunity object in Microsoft CRM, and then click the Sales Process tab. The sales process stages that you previously saw are now missing.
If you complete one of the tasks from the existing sales process for the Opportunity object, Workflow Manager will create the next task that is listed in the sales process.

REFERENCES


Modification Type:MinorLast Reviewed:9/8/2006
Keywords:kbHotfixServer kbQFE kbMBSworkflow kbMBSMigrate kbBug kbprb KB831181 kbAudEndUser