You cannot import a transportable shadow volume in Windows Server 2003 (831112)



The information in this article applies to:

  • Microsoft Windows Server 2003, Web Edition
  • Microsoft Windows Server 2003, Standard Edition
  • Microsoft Windows Server 2003, Enterprise Edition
  • Microsoft Windows Server 2003, 64-Bit Enterprise Edition

SYMPTOMS

When you try to convert a transportable shadow volume to read/write status, the conversion is not completed. After you import the shadow volume, the hidden flag may be turned on, although you did not set the hidden attribute on the volume. Third-party hardware programs that try to perform this task may not convert the volume.

CAUSE

This problem occurs because the Virtual Disk service caches the hidden flag on the volume. The Virtual Disk service caches the VDS_VF_HIDDEN flag for volumes but does not update the cache when another component, such as the Volume Shadow Copy service, changes the flag. When this problem occurs, the Virtual Disk service reports incorrect values for the hidden flag.

RESOLUTION

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, Microsoft recommends that you wait for the next Windows Server 2003 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services phone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

No prerequisites are required.

Restart requirement

You do not have to restart your computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.

IA-64
   Date         Time   Version            Size    File name
   --------------------------------------------------------------
   07-Nov-2003  13:49  5.2.3790.101      329,728  Vdsbas.dll       IA-64
x86
   Date         Time   Version            Size    File name
   --------------------------------------------------------------
   07-Nov-2003  17:49  5.2.3790.101      105,984  Vdsbas.dll 

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For additional information, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates


Modification Type:MinorLast Reviewed:10/27/2005
Keywords:kbHotfixServer kbQFE kbFileSystems kbWinServ2003preSP1fix kbSysSettings kbMiscTools kbBug kbfix kbQFE KB831112 kbAudITPRO