You receive an "Unable to connect to database" error message when you connect to a Windows SharePoint Services Web site after you upgrade WMSDE to SQL Server 2000 (831105)



The information in this article applies to:

  • Microsoft Windows SharePoint Services

SYMPTOMS

When you connect to a Microsoft Windows SharePoint Services site after you upgrade the instance of Microsoft SQL Server Desktop Engine (Windows) (WMSDE) on the server to Microsoft SQL Server 2000, you may receive the following error message:
Unable to connect to database. Check database connection information and make sure the database server is running.

CAUSE

This issue occurs if the MSSQL$SharePoint service is not started on the server. When you upgrade WMSDE to Microsoft SQL Server on a server that is running Windows SharePoint Services, the MSSQL$SharePoint service is stopped after the upgrade operation.

RESOLUTION

To resolve this issue, do one of the following as appropriate to your situation:
  • Start the MSSQL$SharePoint service. To do so, follow these steps:
    1. Click Start, and then click Run.
    2. In the Open box, type cmd, and then click OK.
    3. At the command prompt, type the following line, and then press ENTER:

      net start mssql$sharepoint

    4. Type exit, and then press ENTER to exit Command Prompt.
  • Restart the server.

MORE INFORMATION

When you upgrade WMSDE to Microsoft SQL Server on a server that is running Windows SharePoint Services, you must restart the MSSQL$SharePoint service after the upgrade operation is complete. To do so, either manually start the service or restart the server.

For additional information about how to install and manage Windows SharePoint Services, see the Microsoft Windows SharePoint Services 2.0 Administrator's Guide. To obtain the Microsoft Windows SharePoint Services 2.0 Administrator's Guide, visit the following Microsoft Web site:

For more information about Windows SharePoint Services, visit the following Microsoft Web site:

Modification Type:MinorLast Reviewed:7/27/2006
Keywords:kbprb kbDatabase kbUpgrade kbWebServices kbtshoot kberrmsg kbnofix KB831105 kbAudITPRO