Administration Service May Not Start After You Run Bootstrap (831100)



The information in this article applies to:

  • Microsoft TV Foundation Server 1.0

SYMPTOMS

Before you run Bootstrap for the first time on a computer that is running Microsoft TV Foundation Server, you must set the Active Directory domain to Native mode. If you do not do this, Bootstrap will fail the first time that you run it.

However, if you experience this issue, and you fix it by promoting your domain to Native mode and running Bootstrap again, the MSTV Administrative Service may not start.

CAUSE

This problem occurs because the MSTV Administrative Service has the wrong access-control list (ACL) configured on the RecorderLite folder.

RESOLUTION

To resolve this problem, follow these steps:
  1. Stop the MSTV Administrative Service (if it is not already stopped).
  2. Open the Configuration\Release folder that is located in the MSTV Server installation folder. Typically, the installation folder is C:\Program Files\Microsoft TV\Basic Server 1.0 NA.
  3. Delete the following file:

    YourController.domain.com.xml

    Note YourController.domain.com is a placeholder for the fully qualified domain name of the controller computer.
  4. In a text editor such as Notepad, edit the ConfigStore.xml file. Delete the following XML tags:
    • <ConfigFile Name="YourController.domain.com.xml">
    • <Version>2003-08-07T11:38:36.3203125-07:00</Version>
    • <FileType>SettingsFile</FileType>
    • </ConfigFile>
  5. Restart the MSTV Administrative Service.
  6. Run Bootstrap again. When you receive the prompt to rebuild the configuration and the databases, click Yes.

Modification Type:MajorLast Reviewed:11/15/2003
Keywords:kbprb KB831100 kbAudDeveloper