You cannot find Visio 2003 XML drawing format (.vdx) files when you search in Visio 2003 (830919)



The information in this article applies to:

  • Microsoft Office Visio Professional 2003
  • Microsoft Office Visio Standard 2003

SYMPTOMS

When you try to search (click Start, and then click Search) for your Microsoft Office Visio 2003 XML drawing format (.vdx) files on your computer, the search results may not find your files.

CAUSE

This behavior may occur when your Visio XML drawing format (.vdx) files are not indexed.

WORKAROUND

To work around this behavior, use one of the following methods.

Method 1: File Search

To search for your Visio XML drawing format (.vdx) files, use the File Search feature in Visio 2003. To do this, follow these steps:
  1. Start Visio 2003.
  2. On the File menu, click File Search.
  3. In the Search for Shapes box, type a description for the type of shape that you want to find.

    For example, type Desk in the Search for Shapes box.
  4. Click Search (the right-pointing arrow button).

Method 2: Indexing Service

To search for your Visio XML drawing format (.vdx) files by using the Search feature in Microsoft Windows, configure the Indexing Service to cache the property that you want to find. To do this, follow these steps:
  1. Click Start, and then click Run.
  2. In the Open box, type mmc, and then click OK.
  3. In the Console1 window, click File, and then click Add/Remove Snap-in.
  4. On the Standalone tab, click Add.
  5. In the Add Standalone Snap-in dialog box, click Indexing Service, and then click Add.
  6. In the Connect to Computer dialog box, select the computer that you want to manage.

    For example, click Local computer (the computer this console is running on), and then click Finish.
  7. In the Add Standalone Snap-in dialog box, click Close.
  8. In the Add/Remove Snap-in dialog box, click OK.

    The Indexing Service is added to Console1.
  9. Right-click Indexing Service, and then click Stop.
  10. Expand Indexing Service in the Console Root.
  11. Expand System.
  12. Click Properties.
  13. In the Friendly Name column, right-click the property that you want to search (such as DocSubject), and then click Properties.
  14. On the Property tab, click to select the Cached check box, select the Datatype and the Size, and then click OK.
  15. Click OK when you receive the following message:Property cache modification takes effect when Indexing Service is restarted. Only newly filtered documents will have the modified set of properties. A Full Rescan should be initiated to extract newly cached properties from already filtered documents.
  16. Right-click System, point to All Tasks, and then click Empty Catalog.
  17. Click Yes when you receive the following message:Deletion of catalog files results in loss of all data needed to search this catalog. Are you sure?
  18. Right-click Indexing Service, and then click Start.
  19. On the File menu, click Exit to close the Console1 window.

Modification Type:MinorLast Reviewed:7/27/2006
Keywords:kbprb KB830919 kbAudEndUser kbAudITPRO