A file in a network folder opens as read-only or returns an error message that the file type cannot be recognized (830903)



The information in this article applies to:

  • Microsoft Windows XP Professional
  • Microsoft Windows XP Home Edition

Important This article contains information about modifying the registry. Before you modify the registry, make sure to back it up and make sure that you understand how to restore the registry if a problem occurs. For information about how to back up, restore, and edit the registry, click the following article number to view the article in the Microsoft Knowledge Base:

256986 Description of the Microsoft Windows Registry

SYMPTOMS

If you open a network folder in Microsoft Windows Explorer, and then try to open a file in that folder, the document may open as read-only or may return an error message that the file type cannot be recognized. For example, if you open a network folder over a slow link, click a file such as a Microsoft Office PowerPoint 2003 presentation, and then quickly double-click to open the file, the file may open as read-only.

CAUSE

This problem occurs because Windows Explorer locks and reads the file to extract the thumbnail that represents the document to populate the Details window of the Show Common Tasks folder view.

RESOLUTION

Service pack information

To resolve this problem, obtain the latest service pack for Microsoft Windows XP. For additional information, click the following article number to view the article in the Microsoft Knowledge Base:

322389 How to obtain the latest Windows XP service pack

Hotfix information

Warning If you use Registry Editor incorrectly, you may cause serious problems that may require you to reinstall your operating system. Microsoft cannot guarantee that you can solve problems that result from using Registry Editor incorrectly. Use Registry Editor at your own risk.

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, Microsoft recommends that you wait for the next Windows XP service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services phone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

The English version of this hotfix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version        Size       File name
   ---------------------------------------------------------
   08-Dec-2003  13:40  6.0.2800.1325  8,241,664  Shell32.dll
After install this hotfix, to enable this feature, you must add the following registry key:
  1. Locate, and then click the following key in the registry:

    For a per-machine policy:

    HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer

    For a per-user policy:

    HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer

  2. On the Edit menu, point to New, and then click DWORD Value.
  3. Type NoDetailsThumbnailOnNetwork, and then press ENTER.
  4. On the Edit menu, click Modify.
  5. Type 1, and then click OK.

WORKAROUND

To work around this problem without installing the hotfix that is described in the "Resolution" section in this article, follow these steps:
  1. In Windows Explorer, open the network folder that contains the file that you are trying to open or save.
  2. On the Tools menu, click Folder Options.
  3. Click Use Windows classic folders, and then click OK.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section of this article. This problem was first corrected in Microsoft Windows XP Service Pack 2.

MORE INFORMATION

This problem can occur to any program that uses the StgOpenStorage function to open the file over a slow link. For example, if you use the Sysinternals Filmon utility when the problem is occurring in Power Point, Powerpnt.exe does not lock the file:
206278  3:16:21 PM       POWERPNT.EXE:3304  LOCK   NOT GRANTED Offset: 2147483539 Length: 20
For additional information, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates


Modification Type:MinorLast Reviewed:10/25/2005
Keywords:kbHotfixServer kbQFE kbWinXPsp2fix kbWinXPpreSP2fix kbfix kbbug KB830903