You cannot open MSDN library files or MMC Help files (830859)



The information in this article applies to:

  • Microsoft Windows Server 2003, Enterprise Edition
  • Microsoft Windows Server 2003, Standard Edition
  • Microsoft Windows XP Home Edition
  • Microsoft Windows XP Professional
  • Microsoft Windows 2000 Advanced Server
  • Microsoft Windows 2000 Professional
  • Microsoft Windows 2000 Server

SYMPTOMS

You may experience any one or both of the following issues:
  • When you try to start the Microsoft Developer Network (MSDN) Library, you may receive the following error message:
    Cannot open C:\Program Files\Microsoft Visual Studio\MSDN98\98VSa\1040\msdnv6a.col
  • When you try to open the Help file from a Microsoft Management Console (MMC) snap-in by clicking Help on the toolbar, the Help file does not open, and you do not receive an error message.

CAUSE

These issues may occur if there is a problem with a tag in the Hhcolreg.dat file. When this issue occurs, the HTML Help viewer cannot interpret the Hhcolreg.dat file.

Note The HTML Help viewer is Hhctrl.ocx.

RESOLUTION

To resolve these issues, edit the Hhcolreg.dat file:
  1. Start Notepad.
  2. Open the Hhcolreg.dat file. To do so, click Start, click Search, click Advanced search options, and then click to select the Search hidden files and folders check box.

    Note The Hhcolreg.dat file is located in the C:\Documents and Settings\All Users\Application Data\Microsoft\HTML Help folder. By default, the Application Data folder is hidden.
  3. Locate the following XML tag:

    <Locations/>

  4. Replace the <Locations/> XML tag with the following XML tag:

    <Locations> </Locations>

  5. Save the file.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section of this article.

Modification Type:MajorLast Reviewed:1/26/2004
Keywords:kbprb KB830859