You receive a "lsass.exe-system error: Security Accounts Manager initialization failed" error message and event ID 1168 is logged when you restart a Windows Server 2003 domain controller (830574)



The information in this article applies to:

  • Microsoft Windows Server 2003, Web Edition
  • Microsoft Windows Server 2003, Standard Edition
  • Microsoft Windows Server 2003, Enterprise Edition
  • Microsoft Windows Server 2003, 64-Bit Enterprise Edition

SYMPTOMS

When you restart a Microsoft Windows Server 2003 server that is a domain controller, you may receive the following error message:
lsass.exe-System Error: Security Accounts Manager initialization failed because of the following error: Directory Service cannot start. Error Status: 0xc00002e1. Please click OK to shutdown this system and reboot into Directory Services Restore Mode, check the event log for more detailed information.
If you use Event Viewer, you see that the following event is logged:Event Type: Error
Event Source: NTDS General
Event Category: Internal Processing
Event ID: 1168
Description:
Internal error: An Active Directory error has occurred.

Additional Data
Error value (decimal): 8374
Error value (hex): 20b6
Internal ID: 30d00fa

CAUSE

This problem may occur if the Active Directory directory service contains duplicate cross-reference objects, and these objects represent domains that are in the Partitions container. If there are duplicate cross-reference objects, Windows Server 2003 cannot initialize the Security Accounts Manager (SAM) and Active Directory cannot start. Examples of how you might create a duplicate cross-reference object include the following:
  • You seize the domain naming operations master role while Active Directory is broken for a long period.
  • You seize the domain naming operations master role. Next, you perform an authoritative restore of Active Directory from a backup that was made before you seized the domain naming master role.
Note Microsoft Windows 2000 domain controllers do not verify all the cross-references. Therefore, Windows 2000 domain controllers do not experience this problem.

RESOLUTION

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Windows Server 2003 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

No prerequisites are required.

Restart requirement

You must restart your computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version            Size    File name   Platform
   -------------------------------------------------------------------
   15-Oct-2003  22:36  5.2.3790.92     1,520,128  Ntdsa.dll   x86     
   15-Oct-2003  23:37  5.2.3790.92     4,008,960  Ntdsa.dll   IA-64


This hotfix permits Active Directory to start so that you can remove the duplicate cross-reference objects. After you install this hotfix, remove the duplicate cross-reference objects from Active Directory. Microsoft recommends that you contact Microsoft Product Support Services for help. To contact Microsoft Product Support Services, visit the following Microsoft Web site:

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

REFERENCES

For more information about cross-reference objects, visit the following Microsoft Web site: For additional information about how to configure Active Directory diagnostic event logging, click the following article number to view the article in the Microsoft Knowledge Base:

314980 How to configure Active Directory diagnostics event logging in Windows 2000

For additional information about Microsoft software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates


Modification Type:MajorLast Reviewed:7/11/2006
Keywords:kbHotfixServer kbQFE kbBug kbfix kbQFE kbWinServ2003preSP1fix KB830574 kbAudITPRO