No Error Is Returned When the 0A1 Relationship Is Not Found (829972)



The information in this article applies to:

  • Microsoft BizTalk Server 2002
  • Microsoft BizTalk Server Accelerator for RosettaNet, version 2.0

Template:CPR - BizTalk - Hotfix

SYMPTOMS

If you use Microsoft BizTalk Server Accelerator for RosettaNet 2.0, and you create a Partner Agreement, you may not receive an error message in the event log if the relationship is not set up correctly.

For example, if you create a Partner Agreement for an F17 of PIPVersion 2.0.2(RNIF1.1) and a 0A1 of PIPVersion V02.00(RNIF1.1) and your partner does not respond, you will not receive an error message in the event log.

Note In the previous example, PIP is Partner Interface Process and RNIF is RosettaNet Implementation Framework.

CAUSE

This problem occurs because of an error in the code of BizTalk Server Accelerator for RosettaNet. If an F17 of PIPVersion 2.0.2(RNIF1.1) and a 0A1 of PIPVersion V02.00(RNIF1.1) are used, the code generates an error that is not reported to the event log.

RESOLUTION

To resolve the problem that appears in the "Symptoms" section, you must create a 0A1 of PIPVersion 1.0. BizTalk Server Accelerator for RosettaNet requires that the 0A1 must be of PIPversion 1.0 for backward compatibility with A4RN 1.1.

If errors occur with RNIF1.1 messages, the ExecutePIP0A1 generates and sends out 0A1 V1.0 schema messages only. The ExecutePIP0A1 must do this to maintain compatibility with A4RN1.

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that this article describes. Apply it only to systems that are experiencing this specific problem.

To resolve this problem, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

The English version of this hotfix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version    Size     File name
   ---------------------------------------------------------
   29-Sep-2003  23:27  3.0.0.560  389,221  Pipadaptersdk.dll
Note Because of file dependencies, the most recent hotfix or feature that contains these files may also contain additional files.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section of this article.

Modification Type:MinorLast Reviewed:10/17/2005
Keywords:kbQFE kbfix kbbug KB829972 kbAudDeveloper