XADM: One Public Folder Does Not Replicate To Other Servers (829968)



The information in this article applies to:

  • Microsoft Exchange 2000 Server

Important This article contains information about modifying the registry. Before you modify the registry, make sure to back it up and make sure that you understand how to restore the registry if a problem occurs. For information about how to back up, restore, and edit the registry, click the following article number to view the article in the Microsoft Knowledge Base:

256986 Description of the Microsoft Windows Registry

SYMPTOMS

In Microsoft Exchange Server 2000, you may find that a public folder does not replicate to other servers. The replication messages (event ID 3020) are logged, but replication messages are not sent.

If you set diagnostic logging to Level 7 for the MSExchangeTransport registry entry , the following event ID message is logged in the Event Viewer:
Event Type: Warning
Event Source: MSExchangeTransport
Event Category: (5)
Event ID: 327
Description: The following call : EcSaveChangesMessage to the store failed. Error code : -1605. MDB : 91cdf406-24aa-4510-961e-b6037ab05647. FID : 1-E. MID : 1-A9FE13. File : .
Note To set diagnostic logging to Level 7 for the MSExchangeTransport registry entry, follow the steps in the More Information section of this article.

CAUSE

This problem may occur if MSExchangeTransport does not update a message ID counter during internal processing. This behavior can cause a duplicate message ID to be generated for all subsequent messages until the original copy of the message is removed. The message that is affected typically appears as a replication message. Public folder replication may stop working after this problem occurs, because messages cannot be sent from the public information store.

RESOLUTION

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Exchange 2000 Server service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.
Component: Information store

The English version of this hotfix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version            Size    File name
   --------------------------------------------------------------
   15-Oct-2003  23:31  6.0.6521.0      3,915,776  Cdoex.dll        
   15-Oct-2003  23:25  6.0.6521.0        851,968  Davex.dll        
   15-Oct-2003  23:25  6.0.6521.0         53,248  Davexpc.dll      
   15-Oct-2003  23:22  6.0.6521.0        131,072  Drviis.dll       
   15-Oct-2003  23:22  6.0.6521.0        577,536  Dsaccess.dll     
   15-Oct-2003  22:33  6.0.6521.0        184,320  Dscmsg.dll       
   15-Oct-2003  22:33  6.0.6521.0        962,560  Emsmdb32.dll     
   15-Oct-2003  23:25  6.0.6521.0      2,179,072  Ese.dll          
   15-Oct-2003  23:25  6.0.6521.0         40,960  Eseperf.dll      
   09-Sep-2003  02:18                      6,991  Eseperf.hxx
   15-Oct-2003  23:25                    391,634  Eseperf.ini
   15-Oct-2003  23:31  6.0.6521.0      3,575,808  Excdo.dll        
   15-Oct-2003  23:22  6.0.6521.0        262,144  Exmime.dll       
   15-Oct-2003  23:25  6.0.6521.0        143,360  Exodbesh.dll     
   15-Oct-2003  23:25  6.0.6521.0         57,344  Exodbpc.dll      
   15-Oct-2003  23:25  6.0.6521.0        200,704  Exodbprx.dll     
   15-Oct-2003  23:25  6.0.6521.0      2,179,072  Exoledb.dll      
   15-Oct-2003  23:20  6.0.6521.0         81,920  Exosal.dll       
   15-Oct-2003  23:25  6.0.6521.0        307,200  Exprox.dll       
   15-Oct-2003  22:36  6.0.6521.0        143,360  Exschema.exe     
   15-Oct-2003  23:25  6.0.6521.0        315,392  Exsmtp.dll       
   15-Oct-2003  22:38  6.0.6521.0        675,840  Exwform.dll      
   15-Oct-2003  23:23  6.0.6521.0         40,960  Jcb.dll          
   15-Oct-2003  22:13  6.0.6521.0         49,152  Mdbevent.dll     
   15-Oct-2003  22:30  6.0.6521.0      2,285,568  Mdbmsg.dll       
   15-Oct-2003  22:15  6.0.6521.0         32,768  Mdbrole.dll      
   15-Oct-2003  23:23  6.0.6521.0         24,576  Mdbtask.dll      
   15-Oct-2003  23:19  6.0.6521.0         94,208  Peexch50.dll     
   15-Oct-2003  23:20  6.0.6521.0        397,312  Phatcat.dll      
   15-Oct-2003  23:23  6.0.6521.0        532,480  Reapi.dll        
   15-Oct-2003  23:25  6.0.6521.0        311,296  Resvc.dll        
   15-Oct-2003  23:21  6.0.6521.0      4,657,152  Store.exe        
   15-Oct-2003  22:38  6.0.6521.0      3,735,552  Wmtemplates.dll  
 				
Note Because of file dependencies, this hotfix requires Exchange 2000 Server Service Pack 3 (SP3). For additional information, click the following article number to view the article in the Microsoft Knowledge Base:

301378 How to Obtain the Latest Exchange 2000 Server Service Pack

MORE INFORMATION

To turn on Level 7 Diagnostic Logging, follow these steps.

Warning If you use Registry Editor incorrectly, you may cause serious problems that may require you to reinstall your operating system. Microsoft cannot guarantee that you can solve problems that result from using Registry Editor incorrectly. Use Registry Editor at your own risk.
  1. Click Start, click Run, type regedit in the Open box, and then click OK.
  2. Locate and then click the following key in the registry:

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\MSExchangeTransport\Diagnostics

  3. On the Edit menu, point to New, and then click DWORD Value.
  4. Type 5 Exchange Store Driver for the name of the DWORD, and then press ENTER.
  5. Right-click 5 Exchange Store Driver, and then click Modify.
  6. In the Value data box, type 00000007, and then click OK.
  7. Quit Registry Editor.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section of this article.

Modification Type:MinorLast Reviewed:10/3/2005
Keywords:kbHotfixServer kbQFE kberrmsg kbQFE kbfix kbExchange2000preSP4fix kbbug KB829968 kbAudITPRO