Important This article contains information about modifying the registry.
Before you modify the registry, make sure to back it up and make sure that you
understand how to restore the registry if a problem occurs. For information
about how to back up, restore, and edit the registry, click the following
article number to view the article in the Microsoft Knowledge Base:
256986 Description of the Microsoft Windows Registry
SYMPTOMS
When you set the value of the
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Lsa\crashonauditfail
registry subkey to 1 on a Microsoft Windows Server 2003-based computer, the
following error message may appear when you shut down the Windows Server
2003-based computer:
Stop Error: 0xC0000244
{Audit Failed}
An Attempt to Generate a Security Audit
Failed
Clients will receive the following error when they try to gain access to the server:
Logon failure: user account restriction. Possible reasons are blank passwords not allowed, logon hour restrictions, or a policy restriction has been enforced.
CAUSE
This problem may occur when the
crashonauditfail
registry subkey is given a value of
1 and the following timing
issue occurs: While the system is in the process of shutting down there is an
attempt to write an audit event.
The valid range for the
crashonauditfail registry value is 0 through 2. The following
table describes each value:
|
| 0 | Anyone can log on to the computer. |
| 1 | The system will halt if it cannot write an audit
log event. |
| 2 | Only Administrators can log on to the
computer. |
RESOLUTION
Hotfix information
A supported hotfix is now
available from Microsoft, but it is only intended to correct the problem that
is described in this article. Only apply it to systems that are experiencing
this specific problem. This hotfix may receive additional testing. Therefore,
if you are not severely affected by this problem, Microsoft recommends that you
wait for the next Windows Server 2003 service pack that contains this
hotfix.
To resolve this problem immediately, contact Microsoft Product
Support Services to obtain the hotfix. For a complete list of Microsoft Product
Support Services phone numbers and information about support costs, visit the
following Microsoft Web site:
Note In special cases, charges that are ordinarily incurred for
support calls may be canceled if a Microsoft Support Professional determines
that a specific update will resolve your problem. The usual support costs will
apply to additional support questions and issues that do not qualify for the
specific update in question.
Prerequisites
No prerequisites are required
Restart requirement
You must restart your computer after you apply this hotfix.
Hotfix replacement information
This hotfix does not replace any other hotfixes.
File information
The English version of this hotfix has the file
attributes (or later) that are listed in the following table. The dates and
times for these files are listed in coordinated universal time (UTC). When you
view the file information, it is converted to local time. To find the
difference between UTC and local time, use the
Time Zone tab
in the Date and Time tool in Control Panel.
Date Time Version Size File name
----------------------------------------------------
25-Sep-2003 17:39 5.2.3790.89 800,256 Lsasrv.dll