Web site changes are not visible on the destination Web server in FrontPage 2003 (828904)



The information in this article applies to:

  • Microsoft Office FrontPage 2003

For a Microsoft FrontPage 2002 version of this article, see 299867.
For a Microsoft FrontPage 2000 version of this article, see 266430.

SYMPTOMS

In Microsoft Office FrontPage 2003, when you make changes to your Web site on your local computer and then publish the Web site to another Web server, the changes do not appear on the destination Web server.

CAUSE

This behavior may be caused by one of the following causes.

Cause 1: No default document exists or the default document is incorrect

You published your Web without a default document, or your default document does not match the Web server's configuration.

Cause 2: You are viewing a cached Web page

You are viewing the old version of your Web page that is stored in your Web browser's cache.

Cause 3: You did not copy all the files when you used File Transfer Protocol

You did not copy all the files to the Web server when you used a third-party File Transfer Protocol (FTP) program.

Cause 4: The publish operation was interrupted

The publish operation was interrupted or canceled.

Cause 5: You published your Web site to a staging server

You published your Web site to a staging server, but you are viewing the production server.

Cause 6: The Web page is excluded from the publishing process

The properties of the Web page are set to exclude the page from the publishing process. There are several locations where you can exclude a file from the publishing process:
  • The Folders view.
  • The Remote Web Site view.
  • The Web page Properties dialog box.
  • The Publish Status report.

RESOLUTION

Resolution 1: Rename or create your default document

To resolve this problem, rename or create your default document to match the configuration of the Web server. Web servers use a default document that is displayed if a specific Web page is not specified. For additional information about how to rename your default document, click the following article number to view the article in the Microsoft Knowledge Base:

307243 New home page is not displayed in browser after you publish your Web



Note Microsoft Internet Information Services (IIS) typically uses Default.htm as its default document. UNIX-derivative Web servers typically use index.html as their default document.

If you are not sure of the configuration of the Web server, contact the server's administrator for more information.

Resolution 2: Clear your Web browser's cache

The cache in Microsoft Internet Explorer loads previously visited Web page content more quickly and reduces network traffic. To increase performance, Internet Explorer opens Web page content from the cache in memory instead of from the hard disk or from the server. To clear the Internet Explorer cache, follow these steps:
  1. Start Internet Explorer.
  2. On the Tools menu, click Internet Options.
  3. On the General tab, click Delete Files under Temporary Internet files.
  4. In the Delete Files dialog box, click to select the Delete all offline content check box if you want to delete all Web page content that you have made available offline.
  5. Click OK two times.

Resolution 3: Use FTP in FrontPage 2003 to publish your Web

When you use a third-party FTP program to copy your Web to an Internet server, you must copy all the files in your Web's content folder. If some files are not copied to the destination Web, some FrontPage components may not appear as expected or function as expected. For example, a theme component may not function as expected.

To correct this problem, use FTP in FrontPage 2003 to publish your Web.

Note You may be able to correct the problem by recalculating the hyperlinks in your Web. To do this, follow these steps:
  1. Open your Internet Web site in FrontPage 2003. To do this, click Open Site on the File menu.
  2. On the Tools menu, click Recalculate Hyperlinks, and then click Yes when you are prompted to continue.
  3. On the File menu, click Close Site.

Resolution 4: Republish your Web

If the network connection was lost during publishing, or if the publishing process was canceled, use the Publish Site command on the File menu to republish your Web.

Resolution 5: View the changes on the staging server

Some larger organizations use staging servers and production servers. A staging server is used to test new Webs. The production server is the server that stores the final Web sites that are viewable on the Internet.

If you are publishing your Web site to a staging server, make sure that you view the changes from the staging server. The Web will not be visible on the production server until the Web is copied there.

Resolution 6: Include the Web page in publishing

To include the Web page file in the publishing process, use one of the following methods.

Method a: Folders view

In Folders view, right-click the file that is not published, and then click Don't Publish to cancel the selection.

Note To switch to Folders view, click Folders on the View menu.

Method b: Remote Web Site view

  1. In Remote Web Site view, look for the file that has a status of Don't Publish in the Status column in the Local Web site pane.

    Note To switch to Remote Web Site view, click Remote Web Site on the View menu.
  2. Right-click the file that has a status of Don't Publish, and then click Don't Publish to cancel the selection.

Method c: Web page Properties dialog box

  1. On the View menu, click Folders.
  2. Right-click the file, and then click Properties.
  3. Click the Workgroup tab.
  4. Click to clear the Exclude this file when publishing the rest of the Web check box, and then click OK.

Method d: Publish Status report

  1. On the View menu, point to Reports, point to Workflow, and then click Publish Status.
  2. In the Publish column, right-click the Web page file name that is not published, and then click Don't Publish to cancel the selection.

MORE INFORMATION

For more information about Web publishing in FrontPage 2003, click Microsoft Office FrontPage Help on the Help menu, type Web publishing in the Search for box, and then press ENTER to view the topics that are returned.

Modification Type:MinorLast Reviewed:1/6/2006
Keywords:kbweb kbprb KB828904 kbAudEndUser