Event 5774 occurs in Windows Server 2003 (828333)



The information in this article applies to:

  • Microsoft Windows Server 2003, Web Edition
  • Microsoft Windows Server 2003, Standard Edition
  • Microsoft Windows Server 2003, Enterprise Edition
  • Microsoft Windows Server 2003, 64-Bit Enterprise Edition

SYMPTOMS

On a computer that is running Microsoft Windows Server 2003, you may receive an event that is similar to the following:

Event Type: Error
Event Source: NETLOGON
Event Category: None
Event ID: 5774
Date:  Date
Time:  Time
User:  N/A
Computer: Computer_Name
Description: The dynamic registration of the DNS record 'DNS_Record_Name' failed on the following DNS server: 
DNS Server IP address: IP_Address
Returned Response Code (RCODE): 5 Returned Status Code: 10048

CAUSE

This problem occurs because Microsoft Windows Server 2003 does not support the MaxFreeTWTcbs registry value to control the number of transport control blocks in a time-wait state.

When a Transport Control Protocol (TCP) connection is closed, the socket pair is put in a time-wait state. This state prevents a new connection from immediately using the same protocol, source IP address, destination IP address, source port, and destination port as the closed connection. Therefore, any segments that may have been misrouted or delayed are not delivered unexpectedly.

RFC 793 specifies the length of time that the socket pair may not be reused as two maximum segment lifetimes (MSL), or four minutes. However, with this default setting, network applications that perform many outgoing connections in a short time may use up all available ports before the ports can be recycled.

RESOLUTION

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Windows Server 2003 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

No prerequisites are required.

Restart requirement

You must restart your computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
Microsoft Windows Server 2003, 32-bit editions
   Date         Time   Version            Size    File name
   --------------------------------------------------------------
   19-Aug-2004  01:11  5.2.3790.201      335,360  Tcpip.sys
Microsoft Windows Server 2003, 64-Bit Edition
   Date         Time   Version            Size    File name
   --------------------------------------------------------------
   19-Aug-2004  01:06  5.2.3790.201      972,800  Tcpip.sys

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

Modification Type:MinorLast Reviewed:10/25/2005
Keywords:kbHotfixServer kbQFE kbBug kbfix kbQFE kbWinServ2003preSP1fix KB828333 kbAudITPRO