Write operations to an external storage device take a long time to complete (828012)



The information in this article applies to:

  • Microsoft Windows XP Home Edition SP1
  • Microsoft Windows XP Professional SP1
  • Microsoft Windows XP 64-Bit Edition Version 2002 SP1

SYMPTOMS

When you write data to an external storage device such as a USB flash card reader or a Magneto-Optical (MO) drive, it may take a very long time for all the data to be written to the device. If you examine a bus trace of that device, you notice that there are many duplicate write operations (where the same data is written to the same destination).

CAUSE

This problem occurs because pages of data that are marked to be written to the storage device may be written by the modified page writer or the mapped page writer (these components are part of the Memory Manager) and to the lazy writer component (this component is part of the Cache Manager). These two write operations do not correctly synchronize their lists of pages that are to be written to the device. Therefore, a duplicate write operation may occur. This duplicate write operation causes performance degradation because the same information is written two times to the same storage device.

RESOLUTION

Service pack information

To resolve this problem, obtain the latest service pack for Microsoft Windows XP. For additional information, click the following article number to view the article in the Microsoft Knowledge Base:

322389 How to obtain the latest Windows XP service pack

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Microsoft Windows XP service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services phone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

You must have Windows XP Service Pack 1 (SP1) installed before you install this hotfix.

For additional information about how to obtain Service Pack 1 for Windows XP, click the following article number to view the article in the Microsoft Knowledge Base:

322389 How to obtain the latest Windows XP service pack

Restart requirement

You must restart your computer to apply the changes after you install this hotfix. However, you do not have to restart your computer immediately after you install this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.

Microsoft Windows XP SP1 32-Bit

   Date         Time   Version            Size    File name
   --------------------------------------------------------------
   22-Apr-2004  22:21  5.1.2600.1518   1,912,320  Ntkrnlmp.exe     
   22-Apr-2004  22:21  5.1.2600.1518   1,968,128  Ntkrnlpa.exe     
   22-Apr-2004  22:21  5.1.2600.1518   1,940,480  Ntkrpamp.exe     
   22-Apr-2004  23:01  5.1.2600.1518   2,063,872  Ntoskrnl.exe     

Microsoft Windows XP 64-Bit Edition Version 2002 SP1

   Date         Time   Version            Size    File name
   --------------------------------------------------------------
   22-Apr-2004  22:25  5.1.2600.1518   5,830,144  Ntkrnlmp.exe     IA-64
   22-Apr-2004  22:25  5.1.2600.1518   5,773,568  Ntoskrnl.exe     IA-64
Warning To download the correct hotfix, select the package that has a CreateDate value of 4/27/2004, not the package that has a CreateDate value of 10/20/2003. The correct download files will have the file attributes that this article lists earlier.

Use the Ntorkrnl.exe file version to determine the hotfix version that is installed on your computer. To do this, follow these steps:
  1. Click Start, click Search, and then click All Files and Folders.
  2. In the All or part of the file name box, type ntoskrnl.exe, and then click Search.
  3. After the search results are displayed, right-click the Ntoskrnl.exe file in your Windows\System32 folder, and then click Properties to view the Modified date.

WORKAROUND

To work around this problem, turn off write caching for the storage device. For a USB or removable storage device, configure the caching policy to use the Optimize for quick removal option in Device Manager. To do this, follow these steps:
  1. Click Start, right-click My Computer, and then click Properties.
  2. Click the Hardware tab, and then click Device Manager.
  3. Expand Disk Drives, right-click your storage device, and then click Properties.
  4. Click the Policies tab, click Optimize for quick removal, and then click OK.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section. This problem was first corrected in Microsoft Windows XP Service Pack 2.

MORE INFORMATION

This problem only affects Windows XP with SP1 installed or integrated. It does not affect Windows XP without SP1 installed, Microsoft Windows 2000, or Microsoft Windows Server 2003.

Modification Type:MinorLast Reviewed:10/28/2005
Keywords:kbHotfixServer kbQFE kbQFE kbWinXPsp2fix kbHardware kbWinXPpreSP2fix kbfix kbbug KB828012 kbAudEndUser