The index is not propagated, and an "Index propagation to Search server <ServerName> was not stopped" message is logged in the application event log (827846)



The information in this article applies to:

  • Microsoft Office SharePoint Portal Server 2003

SYMPTOMS

You may find that indexes are not propagated correctly from the index management server to the search server or to servers in your server farm deployment of Microsoft Office SharePoint Portal Server 2003. When you search the portal site, no documents are returned in the search results. Additionally, an event error message with a description that is similar to the following is logged to the application event log of the index management and job server:
Index propagation to Search server ServerName was not stopped. Repropagate the index. Context: http://ServerName1:8001/ Application, Non_Portal_Content Catalog Details: A connection with the Search service on a remote machine could not be established. Check the connectivity with the remote machine. If necessary, stop and restart the Search service on the remote machine. (0x8004111a)

CAUSE

This problem may occur in situations when the search application is either damaged or is partially created and as a result, the indexes are not propagated correctly from the index management server to the search server or to servers in your server farm.

WORKAROUND

To work around this problem, remove the search servers from your server farm topology, and then add the search servers back to your server farm. When you do so, SharePoint Portal Server 2003 deletes and then recreates the search application. To do so, follow these steps:
  1. Start SharePoint Central Administration.
  2. In the Server Configuration area, click Configure server topology.
  3. Remove the search server or search servers from the topology. To do so, follow these steps:
    1. On the Configure Server Topology page, click Change Components.
    2. On the Change Component Assignments page, in the Component Assignment area, click to clear the Search check box next to the server or servers in your server farm that are configured as search servers.
    3. Click OK.
    SharePoint Portal Server 2003 deletes the search application. You can monitor the application event log on the server for an event that indicates that the search application is deleted. After the search program is deleted, go to step 4.
  4. Add the search server or search servers that you removed earlier in step 3 back to the topology. To do so, follow these steps:
    1. On the Configure Server Topology page, click Change Components.
    2. On the Change Component Assignments page, in the Component Assignment area, click to select the Search check box next to the server or servers in your server farm that are configured as search servers.
    3. Click OK.
    Note If you want search results to be available as soon as possible after you did the search server back to the topology, you have to propagate the content index to the search server. For more information about how to propagate a content index, see the "Managing Index Propagation" topic in the "Manage Search Settings" section in the "Administration" chapter of the Microsoft Office SharePoint Portal Server 2003 Administration Guide.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article.

MORE INFORMATION

For more information about how to administer and configure SharePoint Portal Server 2003, see the Microsoft Office SharePoint Portal Server 2003 Administration Guide. The Microsoft Office SharePoint Portal Server 2003 Administration Guide (Administrator's Help.chm) is located in the Docs folder in the root of the SharePoint Portal Server 2003 CD.

For more information about SharePoint Portal Server 2003, visit the following Microsoft Web site:

Modification Type:MinorLast Reviewed:1/9/2006
Keywords:kberrmsg kbpending kbBug KB827846 kbAudITPRO