Delegates receive an "access denied" error message after you delegate rights to change query-based distribution group objects (827665)



The information in this article applies to:

  • Microsoft Exchange Server 2003 Enterprise Edition
  • Microsoft Exchange Server 2003 Standard Edition

SYMPTOMS

When you delegate rights to users to change query-based distribution group objects, those users cannot modify object permissions such as the displayNamePrintable attribute by using the Active Directory Users and Computers snap-in. The users may also receive the following error message:
Access Denied

CAUSE

This problem may occur when a user tries to modify an attribute that the user has permissions for, but the Active Directory Users and Computers snap-in incorrectly tries to modify other attributes at the same time. Because the user does not have sufficient permissions to modify these other attributes, the user experiences the symptoms that are described in the "Symptoms" section.

RESOLUTION

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, Microsoft recommends that you wait for the next Microsoft Exchange 2003 Server service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services phone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question. Component: ADMIN The English version of this hotfix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.

Date         Time   Version        Size        File name
--------------------------------------------------------------
03-Oct-2003  00:25  6.5.6980.32    14,193,664  Maildsmx.dll

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

Modification Type:MinorLast Reviewed:10/3/2005
Keywords:kbHotfixServer kbQFE kbExchange2003preSP1fix kbQFE kbfix kbbug KB827665