The "net use" command does not work and generates error 58 (ERROR_BAD_NET_RESPONSE) in Windows 2000 SP4 (827655)



The information in this article applies to:

  • Microsoft Windows 2000 Server
  • Microsoft Windows 2000 Professional
  • Microsoft Windows 2000 Advanced Server

SYMPTOMS

If you try to connect from one computer that is running Microsoft Windows 2000 Service Pack 4 (SP4) to another computer that is running Windows 2000 SP4, the client computer may not connect and may generate error 58 (ERROR_BAD_NET_RESP). This problem does not occur if the client computer is running any Windows 2000 service pack that is earlier than SP4. The problem may occur when you use the net use command, or the problem may occur when a program on the client computer tries to create a connection by using the WNetAddConnection2 function.

CAUSE

The problem is caused by an error that occurs when the negotiate response for the network connection is validated.

RESOLUTION

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that this article describes. Apply it only to systems that are experiencing this specific problem.

To resolve this problem, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

This hotfix applies to computers that are running Windows 2000 SP4.

Restart requirement

You must restart your computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version        Size     File name
   ------------------------------------------------------
   04-Sep-2003  22:35  5.0.2195.6816  407,792  Mrxsmb.sys
   04-Sep-2003  22:35  5.0.2195.6816  169,712  Rdbss.sys

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For additional information, click the following article number to view the article in the Microsoft Knowledge Base:

816915 New file naming schema for Microsoft Windows software update packages


Modification Type:MinorLast Reviewed:10/28/2005
Keywords:kbHotfixServer kbQFE kbBug kbfix kbQFE kbWin2000preSP5fix KB827655