"The Logon User Interface DLL Logonrem.dll Failed to Load" Error Message After You Remove the Control IT Program (826890)



The information in this article applies to:

  • Microsoft Windows 2000 Advanced Server
  • Microsoft Windows 2000 Professional
  • Microsoft Windows 2000 Server

Important This article contains information about modifying the registry. Before you modify the registry, make sure to back it up and make sure that you understand how to restore the registry if a problem occurs. For information about how to back up, restore, and edit the registry, click the following article number to view the article in the Microsoft Knowledge Base:

256986 Description of the Microsoft Windows Registry

SYMPTOMS

When you install and then remove the Control IT program from Computer Associates International, Inc., and then you restart your computer, you receive the following error message:
User Interface Failure
The logon user interface dll logonrem.dll failed to load. Contact your system administrator.

CAUSE

This issue occurs because the GinaDLL value in the registry points to the Logonrem.dll file. This is a third-party DLL from Computer Associates that is installed with Control IT.

RESOLUTION

WARNING: If you use Registry Editor incorrectly, you may cause serious problems that may require you to reinstall your operating system. Microsoft cannot guarantee that you can solve problems that result from using Registry Editor incorrectly. Use Registry Editor at your own risk. To resolve this issue, you must start Windows in Safe mode and then edit the registry. To do this, follow these steps:
  1. Restart your computer. When Windows startup begins, press F8 to open the Windows 2000 Advanced Options menu.
  2. Use the UP ARROW or the DOWN ARROW key to select Safe Mode, and then press ENTER.
  3. Click Start, click Run, type regedit in the Open box, and then click OK.
  4. In Registry Editor, expand the following key

    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon

    and then click Winlogon.
  5. In the right pane, right-click GinaDLL, and then click Delete.
  6. Quit Registry Editor, and then restart your computer.

MORE INFORMATION

The third-party products that this article discusses are manufactured by companies that are independent of Microsoft. Microsoft makes no warranty, implied or otherwise, regarding the performance or reliability of these products.

Modification Type:MajorLast Reviewed:8/30/2003
Keywords:kberrmsg kbprb KB826890 kbAudITPRO