Certificates other than logon certificates on a smart card are not propagated to the local certificate store of the user in Windows Server 2003 (826817)



The information in this article applies to:

  • Microsoft Windows Server 2003, Standard Edition
  • Microsoft Windows Server 2003, Enterprise Edition
  • Microsoft Windows Server 2003, 64-Bit Enterprise Edition

SYMPTOMS

When a user uses smart card authentication to log on to a domain in Microsoft Windows Server 2003, only the logon certificate is propagated to the local certificate store of the user. The logon certificate is the key pair from the default container. Other certificates that are on the smart card are not propagated to the local certificate store of the user. For example, certificates for signing or encrypting e-mail messages are not propagated to the local certificate store of the user.

CAUSE

This problem occurs when the smart card contains more than one certificate and when the secondary certificate is not a logon certificate.

RESOLUTION

Service pack information

To resolve this problem, obtain the latest service pack for Windows Server 2003. For more information, click the following article number to view the article in the Microsoft Knowledge Base:

889100 How to obtain the latest service pack for Windows Server 2003

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Windows Server 2003 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

No prerequisites are required

Restart requirement

You must restart your computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel. Windows Server 2003, 64-bit versions
   Date         Time   Version      Size     File name     Platform
   ----------------------------------------------------------------
   18-Aug-2003  20:27  5.2.3790.78  219,648  Wlnotify.dll  IA-64
Windows Server 2003, 32-bit versions
   Date         Time   Version      Size    File name
   -----------------------------------------------------
   18-Aug-2003  20:32  5.2.3790.78  89,088  Wlnotify.dll

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

This problem was first corrected in Windows Server 2003 Service Pack 1.

MORE INFORMATION

After you install Windows Server 2003 Service Pack 1 (SP1) or this hotfix, when a user logs on by using smart card authentication, all certificates on the smart card are propagated to the local certificate store of the user. Programs such as Microsoft Outlook locate certificates by looking in this store. If an S/MIME certificate is stored on the smart card, it is propagated to this store. This behavior lets the user help secure e-mail by using a smart card.

Modification Type:MinorLast Reviewed:10/26/2005
Keywords:kbHotfixServer kbQFE kbHotfixServer kbQFE kbWinServ2003SP1fix kbBug kbfix kbWinServ2003preSP1fix KB826817 kbAudITPRO