An unattended installation of Windows Server 2003 cannot continue and you receive a message with error code 18 (826508)



The information in this article applies to:

  • Microsoft Windows Server 2003, Web Edition
  • Microsoft Windows Server 2003, Standard Edition
  • Microsoft Windows Server 2003, Enterprise Edition
  • Microsoft Windows Server 2003, 64-Bit Enterprise Edition

SYMPTOMS

When you try to perform an unattended installation of Microsoft Windows Server 2003, and the Unattend.txt file includes the setup command entry OEMPreinstall = Yes, the Setup program generates the following error message:
File file_name could not be loaded. Error code is 18.
Setup cannot continue.
Press any key to continue.

CAUSE

This problem occurs when the computer that you are installing Windows Server 2003 on supports the OEM Virtual Disk feature, and the Unattend.txt file does not specify any files to be preinstalled. Under these conditions, the Setup loader program does not use the OEM Virtual Disk to locate any third-party device drivers.

Note The OEM Virtual Disk feature was created by various original equipment manufacturers so that you can load third-party drivers on the virtual disk for use in unattended installations.

RESOLUTION

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Windows Server 2003 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

No prerequisites are required.

Restart requirement

You do not have to restart your computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel. Windows Server 2003, 32-bit editions
   Date         Time   Version       Size     File name
   -------------------------------------------------------
   11-Apr-2004  06:53  5.2.3790.161  431,616  Setupdd.sys
   22-Apr-2004  16:40                278,688  Setupldr.bin
   22-Apr-2004  16:40  5.2.3790.165  259,072  Setupldr.exe
Windows Server 2003, 64-Bit Enterprise Edition
   Date         Time   Version       Size     File name
   -------------------------------------------------------
   11-Apr-2004  06:23  5.2.3790.161  899,584  Setupdd.sys

Hotfix installation information

After you extract the hotfix files, you must move them to the I386 or to the IA64 folder, depending on your edition of Windows Server 2003. Windows Server 2003, 32-bit editionsTo complete installation on a 32-bit edition of Windows Server 2003, follow these steps:
  1. Locate the I386 folder in the Windows Server 2003 Setup folders on the network share.
  2. Rename the following files by appending the .bak extension to each file name:
    • Setupdd.sy_
    • Setupldr.bin
    • Setupldr.ex_
  3. Copy the following hotfix files to the I386 folder:
    • Setupdd.sys
    • Setupldr.bin
    • Setupldr.exe
  4. If you plan to use a custom CD to perform the installation, make a new CD that contains the hotfix files.
Windows Server 2003, 64-Bit Enterprise Edition To complete installation on a 64-bit edition of Windows Server 2003, follow these steps:
  1. Locate the IA64 folder in the Windows Server 2003 Setup folders on the network share.
  2. Rename the Setupdd.sy_ file by appending the .bak extension to the file name.
  3. Copy the Setupdd.sys hotfix file to the IA64 folder.
  4. If you plan to use a custom CD to perform the installation, make a new CD that contains the hotfix files.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For additional information about the terminology that is used in this article, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates


Modification Type:MinorLast Reviewed:10/27/2005
Keywords:kbHotfixServer kbQFE kbsetup kbBug kbfix kbQFE kbWinServ2003preSP1fix KB826508 kbAudITPRO