PRB: Installation of Runtime Deployment Package May Fail in Windows 98 (826280)



The information in this article applies to:

  • Microsoft Office XP Developer
  • Microsoft Access 2002
  • Microsoft Windows 98

This article applies only to a Microsoft Access database (.mdb).

Moderate: Requires basic macro, coding, and interoperability skills.

SYMPTOMS

When you try to install a Microsoft Access 2002 runtime deployment package on a computer that is running Microsoft Windows 98, the installation may fail and you may receive the following error message:
The Office System Pack cannot be installed on this system because the languages are not the same. Install the Office System Pack for the appropriate language on your computer. For assistance, contact your application provider.

CAUSE

This problem occurs because the Access 2002 runtime deployment package is created on a computer (the development computer) with different regional settings than the settings that are on the destination computer (the client computer).

WORKAROUND

To work around this problem, change the regional settings either at the development computer (where the Access 2002 runtime deployment package is created) or at the destination computer so that the regional settings on both the computers are the same.

Using the Development Computer

To work around the problem by modifying the regional settings on the development computer, follow these steps:
  1. Change the regional settings of the development computer so that they match the Regional Settings of the destination computer. To do this, follow these steps:
    1. Click Start, point to Settings, and then click Control Panel.
    2. In Control Panel, double-click Regional Options.
    3. On the General tab, click to select the language that is the same as the language of the destination computer from the Your locale (location) list.
    4. Click Apply, and then click OK.
    5. Restart the computer.
  2. Rename the Access Runtime folder on the development computer. By default, the location of the Access Runtime folder is the following:

    InstallationDrive:\Program Files\Microsoft Office Developer\Access Runtime

  3. Start the Packaging Wizard to create a runtime deployment package.

    Note Because the Access Runtime folder is renamed in step 2, Microsoft Office cannot find the required files. As a result, you receive the following error message:
    The Packaging Wizard cannot find one or more of the required Access components in the language you selected.

    Select Create New to create a new set of Access components in this language from an Office CD 1 image. Select Browse to find an existing copy in another location. Which would you like to do?
    When you insert the appropriate Microsoft Office XP CD to resume the task, the runtime files that correspond to the new language in the Regional Settings are copied to the development computer. Then you can create the runtime deployment package for the new Regional Settings.
  4. Install the runtime deployment package that is created in step 3 on the destination computer.

Using the Destination Computer

To work around the problem by modifying the Regional Settings on the destination computer, follow these steps:
  1. Change the Regional Settings of the destination computer so that they match the Regional Settings of the development computer. To do this, follow these steps:
    1. Click Start, point to Settings, and then click Control Panel.
    2. In Control Panel, double-click Regional Settings.
    3. On the Regional Settings tab, click the language in the list that is the same as the language on the development computer.
    4. Click Apply, and then click OK.
    5. Restart the computer.
  2. Install the runtime deployment package that was created on the development computer.
Notice that the runtime deployment package is successfully deployed at the destination computer.

MORE INFORMATION

Steps to Reproduce the Behavior

  1. Identify two computers with the following specifications:
    • Development Computer
      • Microsoft Windows 2000
      • Microsoft Office XP and Microsoft Office XP Developer
      • Regional Options settings set to English-US
    • Target Computer
      • Windows 98
      • Regional Settings settings set to English-Canada
  2. On the development computer, create a runtime deployment package for the Northwind sample database by using the Packaging Wizard. The deployment package must include Access runtime files.
  3. On the destination computer, install the runtime deployment package that is created in step 2.
Notice that the installation of the runtime deployment package at the client computer fails with the error message that is described in the "Symptoms" section of this article.

REFERENCES

For more information about creating a runtime deployment package by using the Packaging Wizard in Microsoft Office XP Developer, visit the following Microsoft Developer Network (MSDN) Web sites: For additional information, click the following article number to view the article in the Microsoft Knowledge Base:

321000 ACC2002: "The Packaging Wizard Cannot Find One or More of the Required Access Components" Error Message


Modification Type:MinorLast Reviewed:12/21/2004
Keywords:kbPackaging kbDeployment kberrmsg kbprb KB826280 kbAudDeveloper