You may receive an "E20251: Failed to enumerate the printers" error message when you run the Security Translation Wizard in Windows Server 2003 (826275)



The information in this article applies to:

  • Microsoft Windows Server 2003, Standard Edition
  • Microsoft Windows Server 2003, Enterprise Edition
  • Microsoft Windows Server 2003, Web Edition
  • Microsoft Windows Server 2003, 64-Bit Enterprise Edition

SYMPTOMS

When you run the Security Translation Wizard in the Active Directory Migration Tool (ADMT) on a Microsoft Windows Server 2003-based computer to update the access control list (ACL) for printers, you may receive an error message that is similar to the following:
E20251: Failed to enumerate the printers on the local machine, rc=122 The data area passed to a system call is too small.
Additionally, this error message is also logged in the Migration.log file.

Note The Migration.log file is stored in the folder where you installed ADMT. Typically, this folder in the %Program Files%\Active Directory Migration Tool folder.

CAUSE

This problem occurs because when you retrieve security information for a printer, ADMT checks if there is enough buffer to hold the data. If there is not enough buffer, a new buffer will be allocated. After ADMT successfully allocates the new buffer, the error status code is not cleared and you receive the error message that is mentioned in the "Symptoms" section.

RESOLUTION

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Windows Server 2003 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

No prerequisites are required.

Restart requirement

You do not have to restart your computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version      Size     File name
   --------------------------------------------------------------------
   04-Aug-2003  17:08  5.2.3790.74  463,360  Mcsdctworkerobjects.dll  
   04-Aug-2003  17:08  5.2.3790.74  536,576  Mcsdctworkerobjectsnt4.dll  

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For additional information, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates


Modification Type:MinorLast Reviewed:10/26/2005
Keywords:kbHotfixServer kbQFE kbHotfixServer kbQFE kbwinservds kbActiveDirectory kbFilePrintservices kbBug kbfix kbQFE kbWinServ2003preSP1fix KB826275 kbAudITPRO