The EVENTTRIGGERS.EXE /T command does not run on the Japanese version of Windows Server 2003 (826266)



The information in this article applies to:

  • Microsoft Windows Server 2003, Web Edition
  • Microsoft Windows Server 2003, Standard Edition
  • Microsoft Windows Server 2003, Enterprise Edition
  • Microsoft Windows Server 2003, 64-Bit Enterprise Edition

SYMPTOMS

When you try to run the Eventtriggers.exe /T command on a Japanese version of Microsoft Windows Server 2003, the command does not run.

CAUSE

This problem occurs because the event logs for this command have not been translated from English to Japanese.
The Eventtriggers.exe /T command forms SQL statements and stores them in the Windows Management Instrumentation (WMI) repository for later use. SQL statements may include error, information, or success event log messages. These event log types have been localized from English to Japanese in the event log database that is managed by the operating system. However, the same event log messages are not localized in the Eventtriggers.exe file. The Eventtriggers.exe /T command correctly forms the SQL query and stores it in the WMI repository for use by the WMI consumer provider, but the WMI consumer provider cannot match the type of event log that the query asks for, and so the WMI consumer provider does not launch the Eventtriggers.exe /T action.

RESOLUTION

Hotfix Information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Windows Server 2003 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

No prerequisites are required.

Restart Requirement

You must restart your computer after you apply this hotfix.

Hotfix Replacement Information

This hotfix does not replace any other hotfixes.

File Information

The English version of this hotfix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.

Windows Server 2003, 32-bit editions



   Date         Time   Version            Size    File name
   --------------------------------------------------------------
   12-Sep-2003  19:38  5.2.3790.84       115,200  Evtrig.exe       

Windows Server 2003, 64-Bit Edition

  

   Date         Time   Version            Size    File name 	Platform
   -------------------------------------------------------------------
   11-Sep-2003  23:22  5.2.3790.84       326,656  Evtrig.exe     IA-64
   12-Sep-2003  19:38  5.2.3790.84       115,200  Wevtrig.exe      x86
   

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section of this article.

MORE INFORMATION

For additional information, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates


Modification Type:MinorLast Reviewed:10/27/2005
Keywords:kbHotfixServer kbQFE kbBug kbfix kbQFE kbWinServ2003preSP1fix KB826266 kbAudITPRO