Author and editor receive "Overlapped save" error when saving a posting (826224)



The information in this article applies to:

  • Microsoft Content Management Server 2002
  • Microsoft Content Management Server 2002 SP1
  • Microsoft Content Management Server 2002 SP1a

SYMPTOMS

When an you click on either Save or Save and Exit to save the posting you are working on, you may receive the following error message although no other author or editor has edited the posting.
Overlapped Save
With this error displayed, you will have the option to Save Regardless on the posting without any further error.

CAUSE

When the user is in authoring mode for a particular posting, Microsoft Content Management Server (MCMS) creates a copy of the original posting. Both the original and the existing posting point to the same object in the cache. The last modified data on this object is updated when the posting is committed. When the server tries to obtain the last modified time of the posting later, the server obtains the updated time. Since the change token is computed based on the updated time, the change token differs from the original one, and the user receives an error message.

RESOLUTION

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Microsoft Content Management Server 2002 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

CMS 2002 Service Pack 1 is required.

Restart requirement

You must restart your computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version        Size  File name
   -----------------------------------------------------------------------------------
   26-Aug-2003  23:16  5.0.2500.0  176,128  Microsoft.contentmanagement.publishing.dll  

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

Modification Type:MinorLast Reviewed:10/26/2005
Keywords:kbHotfixServer kbQFE kbHotfixServer kbQFE kbBug kbfix kbQFE KB826224 kbAudDeveloper