You may receive the "Can't find the database you specified" error message when you open an Access database by using a shortcut (826137)



The information in this article applies to:

  • Microsoft Office Access 2003

Important This article contains information that shows you how to help lower security settings or how to turn off security features on a computer. You can make these changes to work around a specific problem. Before you make these changes, we recommend that you evaluate the risks that are associated with implementing this workaround in your particular environment. If you implement this workaround, take any appropriate additional steps to help protect your system.

This article applies to a Microsoft Access database (.mdb) and to a Microsoft Access project (.adp).

Novice: Requires knowledge of the user interface on single-user computers.
For a Microsoft Access 2002 version of this article, see 304067.
For a Microsoft Access 2000 and Access 97 version of this article, see 235280.

SYMPTOMS

When you try to open an existing Access database by using a shortcut, you may receive the following error message:
Can't find the database you specified, or you didn't specify a database at all.

Specify a valid database name in the command line, and include a path if necessary.

CAUSE

This behavior may occur when one of the following conditions is true:
  • The shortcut points to an earlier version of the Access runtime application, and you chose to upgrade the earlier Office programs during the setup of a later version of Microsoft Office.
  • The Norton AntiVirus software was already installed when you installed Microsoft Office Access 2003.

RESOLUTION

Warning This workaround may make your computer or your network more vulnerable to attack by malicious users or by malicious software such as viruses. We do not recommend this workaround but are providing this information so that you can implement this workaround at your own discretion. Use this workaround at your own risk.

Note An antivirus program is designed to help protect your computer from viruses. You must not download or open files from sources that you do not trust, visit Web sites that you do not trust, or open e-mail attachments when your antivirus program is disabled. For additional information about computer viruses, click the following article number to view the article in the Microsoft Knowledge Base:

129972Computer viruses: description, prevention, and recovery

To resolve the problem that is related to the Access runtime application, follow these steps:
  1. Remove Office Access 2003 from your computer.
  2. Reinstall the Access runtime application.
  3. Verify that you can use the shortcut to open the database of the runtime application.
  4. Reinstall Office Access 2003.

    Note You must make sure that you are not upgrading existing versions of Office during the installation of Microsoft Office Access 2003.
To resolve the problem that is related to Norton AntiVirus software, follow these steps:
  1. Remove Office Access 2003 from your computer.
  2. Remove Norton AntiVirus software from your computer.
  3. Reinstall Office Access 2003.
  4. Verify that you can use the shortcut to open the Access database.
  5. Reinstall Norton AntiVirus software.
If the specified methods do not resolve the problem, manually create a new shortcut. Include the path of the correct version of Msaccess.exe and the path and the file name of the database that you want to open.

For example, in the Target section of the shortcut Properties, enter text that is similar to the following path:

"C:\Program Files\Microsoft Office\Office11\msaccess.exe" "C:\My Documents\mymdb.mdb"

MORE INFORMATION

When you install Microsoft Office 2003 on your computer and an earlier version of Microsoft Office is already installed on your computer, you can choose the option to upgrade the existing Office programs. As a result, the earlier versions of Microsoft Office programs, including the Office programs that are used in the Access runtime applications, are removed from your computer. However, the shortcut or the shortcuts for the Access runtime applications are not also updated. Therefore, when you try to open the Access runtime application by using the shortcut, you may receive the error message that is mentioned in the "Symptoms" section of this article.

The third-party products that this article discusses are manufactured by companies that are independent of Microsoft. Microsoft makes no warranty, implied or otherwise, regarding the performance or reliability of these products.

Modification Type:MajorLast Reviewed:3/8/2005
Keywords:kbopenfile kbDatabase kberrmsg kbprb KB826137 kbAudDeveloper