RAS or RRAS Does Not Start When You Restart a Server That Is Running Windows NT 4.0 (825501)



The information in this article applies to:

  • Microsoft Windows NT Server 4.0

SYMPTOMS

When you restart a server that is running Microsoft Windows NT 4.0, Remote Access Service (RAS) or Routing and Remote Access Service (RRAS) does not start.

If you try to start the Remote Access Connection Manager, you receive the following error message:
Could not start the Remote Access Connection Manager service on \\computer_name.

Error 0126: The specified module could not be found.
The event log shows the following event:Event ID: 20070
Source: RemoteAccess
Type: Error
Category: none

Point to Point Protocol engine was unable to load the module. The specified module could not be found.

CAUSE

This problem may occur if you install the original release of the 823803 security patch on a server that is running Windows NT 4.0. For additional information about this security patch, click the following article number to view the article in the Microsoft Knowledge Base:

823803 MS03-029: A Flaw in a Windows Function Might Allow a Denial of Service

RESOLUTION

On August 13, 2003 Microsoft released an updated 823803 security patch to correct this problem. For additional information about this updated security patch, click the following article number to view the article in the Microsoft Knowledge Base:

823803 MS03-029: A Flaw in a Windows Function Might Allow a Denial of Service

Note Since August 11, 2003, a hotfix (825501) has been available from Microsoft Product Support Services that also corrects this problem. If you have installed this hotfix, you do not need to install the updated 823803 security patch. The following hotfix information can be used to identify if the 825501 hotfix is installed.

File Information

The English version of this fix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version        Size     File name
   --------------------------------------------------------
   25-Jul-2003  14:00  4.0.1381.7226  379,152  Kernel32.dll 

WORKAROUND

To work around this problem, remove the original release of the 823803 security patch. To do this, follow these steps:
  1. Click Start, point to Settings, and then click Control Panel.
  2. Double-click Add/Remove Programs.
  3. Click the Install/Uninstall tab, click Windows NT Hotfix - KB823803, and then click Remove.

STATUS

Microsoft has confirmed that this is a problem in the original release of the 823803 security patch.

Modification Type:MinorLast Reviewed:10/28/2005
Keywords:kbHotfixServer kbQFE kbQFE kbfix kbbug KB825501 kbAudITPRO