"One or more files from the Virtual PC installation is missing" error message when you install Virtual PC on a Windows 98 Second Edition-based computer (825296)



The information in this article applies to:

  • Connectix Virtual PC for Windows version 5.2
  • Connectix Virtual PC for Windows version 5.1
  • Connectix Virtual PC for Windows version 5.0
  • Connectix Virtual PC for Windows version 4.3
  • Connectix Virtual PC for Windows version 4.2
  • Connectix Virtual PC for Windows version 4.1
  • Connectix Virtual PC for Windows version 4.0

Important This article contains information about modifying the registry. Before you modify the registry, make sure to back it up and make sure that you understand how to restore the registry if a problem occurs. For information about how to back up, restore, and edit the registry, click the following article number to view the article in the Microsoft Knowledge Base:

256986 Description of the Microsoft Windows Registry

SYMPTOMS

When you start Virtual PC after you install it on a Microsoft Windows 98 Second Edition-based host computer, you may receive the following error message:
One or more files from the Virtual PC installation is missing. Please reinstall Virtual PC and try again.

CAUSE

This issue may occur if either of the following conditions is true:
  • The Virtual PC Application services (the VPCApp.sys and the VPCPower.sys files) are not installed to the correct folder on the host computer.
  • The host computer does not identify the Virtual PC Application services because a registry setting is incorrect.

RESOLUTION

Warning If you use Registry Editor incorrectly, you may cause serious problems that may require you to reinstall your operating system. Microsoft cannot guarantee that you can solve problems that result from using Registry Editor incorrectly. Use Registry Editor at your own risk.To resolve this issue, follow these steps:
  1. Make sure that the VPCApp.sys and the VPCPower.sys files are located in the system root folder. By default, the system root folder is C:\Windows\System32 or C:\WINNT\System32.

    Search your hard disk to verify the location of these files. If the VPCAppSv.sys and VPCPower.sys files are not located in the system root folder, move the files to the system root folder.
  2. Reinstall the Virtual PC Application Services driver. To do so, follow these steps:
    1. On the host computer, start the Add Hardware Wizard from Control Panel.
    2. Follow the instructions that appear on your screen to manually install a device.
    3. When you are prompted for the device manufacturer and model, click Have Disk.
    4. Locate the following folder:

      Program Files\Connectix\Connectix Virtual PC\Utility\VPCAppSv

    5. Click the VPCAppSv.inf file , and then click OK.
    6. Click Virtual PC Application Services, and then click Next.
    7. Complete the driver installation.
    8. Restart the computer.
  3. Make sure that the ImagePath String value in the following registry key is configured to use the correct path of the VPCAppSv.sys file on your hard disk:

    HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\VPCAppSv.

    To do so, follow these steps:
    1. Click Start, and then click Run.
    2. In the Open box, type regedit, and then click OK.
    3. Locate the following registry key:

      HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\VPCAppSv.

    4. In the right pane, right-click ImagePath, and then click Modify.
    5. In the Edit String dialog box, type %SystemRoot%\System32\Drivers\VPCAppSv.sys in the Value data box, and then click OK.
    6. On the Registry menu, click Exit..
  4. If these steps do not resolve the issue, reinstall Virtual PC.

Modification Type:MajorLast Reviewed:12/12/2003
Keywords:kbprb KB825296 kbAudITPRO