Web Administration Interface Does Not Work Correctly After You Install MS03-018 (825073)



The information in this article applies to:

  • Microsoft Internet Information Services 5.0
  • Microsoft Internet Information Server 4.0

We strongly recommend that all users upgrade to Microsoft Internet Information Services (IIS) version 6.0 running on Microsoft Windows Server 2003. IIS 6.0 significantly increases Web infrastructure security. For more information about IIS security-related topics, visit the following Microsoft Web site:

SYMPTOMS

After you install the security update from the MS03-018 security bulletin, you may notice several issues when you use the Web administration interface (that is, the HTMLA tool) to configure your Microsoft Internet Information Services (IIS) server. If you are using IIS 5.x, you may notice the following:
  • When you try to create a new virtual directory, the operation is not successful, and you receive the following error message:
    Microsoft VBScript runtime error '800a000d' Type mismatch: 'cInt' /iiwiznew.asp, line 88
    Additionally, the Web service logs of your IIS server may contain the following:

    GET /iisess.asp ParentADSPath=IIS%3A//localhost/W3SVC/1&ParentID=2&stype=www&vtype=server|10|800a01c3|Object_not_a_collection 500

  • The properties page for a Web site does not appear.
If you are using Microsoft Internet Information Server (IIS) 4.0, you may notice that no changes to the IIS configuration are saved after you change the configuration in the Web administration interface.

CAUSE

These problems occur because the MS03-018 update makes several changes to the Active Server Pages (ASP) pages of the Web administration interface.

RESOLUTION

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

The English version of this hotfix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version            Size    File name
   -----------------------------------------------------------
   25-Jul-2003  12:35  5.0.2195.6793     14,608   Spiisupd.exe
Note Because this hotfix includes the changes that MS03-018 makes, and the hotfix also corrects the problems that the "Symptoms" section describes, you do not have to install MS03-018 before you install the hotfix.

STATUS

Microsoft has confirmed that this is a bug in MS03-018 (Q811114).

Modification Type:MinorLast Reviewed:1/10/2006
Keywords:kbHotfixServer kbQFE kbHotfixServer kbQFE kbQFE kbfix kbbug KB825073 kbAudDeveloper