Terminal Services Licensing Denies Your Connection to Your Terminal Server from Your WBT Device (825027)



The information in this article applies to:

  • Microsoft Windows 2000 Server SP3
  • Microsoft Windows 2000 Server SP4
  • Microsoft Windows 2000 Advanced Server SP3
  • Microsoft Windows 2000 Advanced Server SP4
  • Microsoft Windows 2000 Professional SP3
  • Microsoft Windows 2000 Professional SP4

SYMPTOMS

When you try to connect to your Terminal server (the server that has Terminal Server enabled) from your Windows-based terminal (WBT) device, the Terminal Services Licensing service may deny your connection.

CAUSE

This problem may occur if all the following conditions are true:
  • You update the electrically erasable programmable read-only memory (EEPROM) of your WBT device.
  • The following subkey is deleted from your registry:

    HKEY_LOCAL_MACHINE\Software\Microsoft\MSLicensing\Store

  • Your WBT device has been issued a new temporary license.
  • You have installed the hotfix that is described in the following Microsoft Knowledge Base article:

    287687 Terminal Services Licensing Enhancements

If all these conditions are true, Terminal Services Licensing may treat your Terminal Services license as expired.

RESOLUTION

Hotfix Information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that this article describes. Apply it only to systems that are experiencing this specific problem.

To resolve this problem, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Important Apply this hotfix to the Terminal Server License Server. Do not apply this hotfix to the Windows-based terminal device.

Prerequisites

No prerequisites are required.

Restart Requirement

You do not have to restart your computer after you apply this hotfix.

Hotfix Replacement Information

This hotfix does not replace any other hotfixes.

File Information

The English version of this fix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version         Size     File name
   --------------------------------------------------------
   30-Jul-2003  11:30  5.0.2195.6794   330,512  Lserver.exe

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article.

MORE INFORMATION

For additional information about how hotfix packages are named, click the following article number to view the article in the Microsoft Knowledge Base:

816915 New Naming Schema for Microsoft Windows Hotfix Packages


Modification Type:MinorLast Reviewed:10/28/2005
Keywords:kbHotfixServer kbQFE kbBug kbfix kbQFE kbWin2000preSP5fix KB825027 kbAudEndUser kbAudITPRO